Support » Plugin: Wordfence Security - Firewall & Malware Scan » Major conflicts via last update

  • Resolved kaotik

    (@kaotik)


    I’ve got multiple sites down because of conflicts that result to other plugins using “ClassLoader.php” and running version 7.1.15 and same conflict persists. Please fix asap!

    • This topic was modified 3 years, 2 months ago by kaotik.
Viewing 15 replies - 1 through 15 (of 26 total)
  • Feel free to implement the workaround I posted here: https://wordpress.org/support/topic/conflict-with-cloudflare-plugin-upon-wordfence-update/

    Until Wordfence release a change that removes the conflicts. Is the exact error you are encountering the includeFile() declaration method having conflicts?

    Hi @kaotik!
    We’re looking in to it. It would help greatly if you could tell us which plugins those are.

    Thread Starter kaotik

    (@kaotik)

    So far it’s the following:

    “Branding Add-on” plugin by Admin Menu Editor pro.
    And the “Hustle” pop-up plugin by WPMU DEV

    I can’t imagine you’re going to do a work around for each plugin that conflicts with this, are you? It seems you may want to look for a different method (that was working previous to this update) since many plugins seem to use the script that’s being conflicted here.

    Anyways, any help you can achieve with an update to resolve these issues is greatly appreciated.

    • This reply was modified 3 years, 2 months ago by kaotik.

    @kaotik, note that I am not part of Wordfence Support. Just another Wordfence user trying to share what I used to workaround this issue so my site had minimal downtime and without having to delete/re-install any plugins. @wfasa could probably correct me if I am incorrect, but I believe the workaround wont cause any negative impact to the site and should also be overwritten in the next upgrade.

    Thread Starter kaotik

    (@kaotik)

    I appreciate your reply fanta8897 and I understood that you’re not part of the core team. I was replying to @wfasa with my latest info, so I’m going to wait until they can resolve an official fix via an update since I have Wordfence running on about 18 sites at the moment.

    Thank you though. I’ll await further word from the Wordfence folks.

    The ClassLoader is also conflicting with WPS Hide Login. PHP errors are preventing logging into sites and also loading pages which have a front-end login which is also loading WPS Hide Login.

    Thanks for the additional information! We’re just having some trouble reproducing this on our test sites so any additional information you can provide is super helpful.

    The edit @fanta8897 as suggested should be fine as a temporary fix.

    @millermultimedia are you getting errors related to WPS Hide Login or is WPS Hide Login just broken as a result of errors being printed out?

    I was getting White Screens due to the PHP error:

    PHP Fatal error: Cannot redeclare Composer\Autoload\includeFile() (previously declared in /public_html/wp-content/plugins/wps-hide-login/vendor/composer/ClassLoader.php:442) in /public_html/wp-content/plugins/wordfence/vendor/composer/ClassLoader.php on line 445

    I applied the @fanta8897 fix and was able to log back into the site and no more white screens. I will check a few other sites as I run this plugin combination on about 40 different WordPress sites.

    Hi @millermultimedia!

    Thanks a bunch that helps. Did you get this error from wps-hide-login even after upgrading to Wordfence 7.1.15?

    Thread Starter kaotik

    (@kaotik)

    Don’t really have additional information. I’m confused now, still running Version 7.1.15 (have not applied @fanta8897’s fix) and I just reactivated the two plugins in conflict (mentioned above) so I could grab the errors and it appears the errors are gone and all is working as should. Granted this is only on one site, I haven’t tested other sites that this conflict was showing up on yet. Before you dismiss this as resolved, it would still be worth looking into why it happened. As of right now, I only documented one of the errors (being that I can’t get the second one since it appears to be working). The previous error I documented is the following:

    AME Branding Add-on-
    Fatal error: Cannot redeclare Composer\Autoload\includeFile() (previously declared in /home/XXXXX/public_html/wp-content/plugins/ame-branding-add-on/vendor/composer/ClassLoader.php:438) in /home/XXXXX/public_html/wp-content/plugins/wordfence/vendor/composer/ClassLoader.php on line 445

    Hi @kaotik!

    We will not be dismissing anything I promise. With 7.1.15 we reverted the changes we had made in 7.1.14 so if we can get confirmation that 7.1.15 works, then we are one step closer to figuring out what went wrong. We definitely don’t want an update to break sites as long as we can avoid it so we’re trying to get all the facts straight here so we can narrow it down and hopefully reproduce the issue on our test servers.

    Thread Starter kaotik

    (@kaotik)

    Hi @wfasa

    I just went through all my affected sites and reactivated these plugins after deactivating from the errors received… and now report all is working good. Perhaps I had some cached content because now all looks good since the 7.1.15 update. No more errors.

    Thanks for your prompt replies and looking into this matter! I hope you can resolve the other issues some users have reported from this.

    Thanks @kaotik!

    That’s great news. We’ll definitely keep a close eye on this. We’ll want to make sure upgrading to .15 fixes this issue for everyone who was affected of course. Then we’ll have to go back to the drawing board and figure out how to implement the changes we wanted to implement in a different way.

    Thanks a bunch!

    I did a quick scan of all of the sites I manage. Out of around 40 sites 3 were having issues. The three with issues had the 7.1.14 update. Two were conflicts with WPS Hide Login. The third was with the plugin “Responsive Menu”. The Responsive Menu conflict was breaking the entire site while the WPS Hide Login conflict only appeared on pages with logins.

    I did an upgrade to 7.1.15 on one of the problematic sites and am seeing no new issues.

    Thanks for the update @millermultimedia. And thanks for providing the additional information. Fingers crossed the other two sites are fine after upgrading to .15 as well.

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘Major conflicts via last update’ is closed to new replies.