Support » Plugin: WordPress MU Domain Mapping » Mainsite: 310 too many redirects

  • Resolved jk91

    (@jk91)


    Hi all,

    At first I want to say that this plugin is really awesome.

    That being said, I have some issues with my mainwebsite which is http://www.jacco-kuiper.nl. When I deactivate the mu domain mapping plugin, my mainsite works like a charm, but as soon as I activate it and go to http://www.jacco-kuiper.nl or jacco-kuiper.nl I get a 310 “too many redirects” error.

    The weird thing is that subsites do work when I activate the mapping plugin. Only the mainsite returns a 310.

    Here is my .htaccess:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    I added the following lines to config.php:

    define(‘SUNRISE’, ‘on’);

    define(‘MULTISITE’, true);
    define(‘SUBDOMAIN_INSTALL’, true);
    define(‘DOMAIN_CURRENT_SITE’, ‘jacco-kuiper.nl’);
    define(‘PATH_CURRENT_SITE’, ‘/’);
    define(‘SITE_ID_CURRENT_SITE’, 1);
    define(‘BLOG_ID_CURRENT_SITE’, 1);

    Any ideas?

    Thanks in advance!

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    Is WordPress installed in the root of your website?

    Jeps.

    wp-admin
    wp-content
    wp-includes
    .htaccess
    index.php

    all those files are in my public_html directory. I’m using wp 3.5.1 fyi.

    Regards

    Plugin Author Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    How are you getting jacco-kuiper.nl to redirect to http://www.jacco-kuiper.nl ?

    Before I installed multisite setup + mu domain mapping plugin I had set both my WordPress Address URL & Site Address URL to respectively:

    http://www.jacco-kuiper.nl/wordpress
    http://www.jacco-kuiper.nl

    And wordpress redirected jacco-kuiper.nl automatically to http://www.jacco-kuiper.nl I guess. I really don’t know how and why it still redirects now.

    Both jacco-kuiper.nl/wp-admin & http://www.jacco-kuiper.nl/wp-admin are accessible by the way. It’s just the frontend.

    I edited this line in index.php:

    /** Loads the WordPress Environment and Template */
    require(‘./wp-blog-header.php’);

    to

    /** Loads the WordPress Environment and Template */
    require(‘wp-blog-header.php’);

    But that doesn’t help.

    Plugin Author Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    If WordPress is in the wordpress folder it is not in the root as you described above. The current version of domain mapping does not support WP installed in its own folder.

    Plugin Author Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    I just finished testing domain mapping with WP 3.5 and WordPress installed in a folder & it works fine.

    Go to Network Admn -> Settings -> Network Setup and get a copy of the rewrite rules. Update your .htaccess with those rules.

    Oh, I now see that I made a mistake in my previous post:

    The first few lines should be:

    Before I installed multisite setup + mu domain mapping plugin I had set both my WordPress Address URL & Site Address URL to respectively:

    http://www.jacco-kuiper.nl/
    http://www.jacco-kuiper.nl/

    I already updated my .htaccess with those rules, but that doesn’t help.

    Also, I tried to import an existing blog to a newly created multisite blog, but the importer doesn’t seem te recognize the multisite setup; it’s as if i’m running a normal WP installation.

    Did you test with http://www.domain.com or domain.com ?

    Thanks

    Plugin Author Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    I apologize – when I copied domain_mapping.php over to the svn I copied one from the wrong folder. I had actually made a few changes to it in the install I was testing in. Earlier today I updated the development version http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/developers/

    Thanks for your answer Ron.

    I tried to use your updated domain_mapping.php file, but that didn’t help either.

    Is it possible that there’s a problem with handling the www.jacco-kuiper.nl? I set up another mu setup a while ago and didn’t use http://www.domain.com, but domain.com, and that worked. But that was quite an old version of WP..

    Plugin Author Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    You downloaded the development version (other versions section) from the page I linked to above?

    If you did can you check the version on your server and post what line # 697 is?

    jk91

    (@jk91)

    Heey Ron,

    I’m sorry I made a mistake. I had downloaded the current (0.5.4.2) version. The development version did the job. Thanks a lot for both the plugin and your help!

    Regards,

    Jacco

    Plugin Author Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    Thanks for posting back and letting me know 🙂

    Kunibert_KA

    (@kunibert_ka)

    Because i found this:

    I just finished testing domain mapping with WP 3.5 and WordPress installed in a folder & it works fine.

    i tried this plugin again, but i still get the ‘This plugin will only work if WordPress is installed in the root directory of your webserver…’

    Did i miss something? I used rev#676675.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Mainsite: 310 too many redirects’ is closed to new replies.