Support » Networking WordPress » Main Site Images 404 Error

  • Erica

    (@ericamdion)


    I’ve used WordPress MS a few times now without trouble, however my current version is really troubling me and I can’t find any other posts with the same problem. I have four sites setup, site ID 1 is mydomain.com and the next 3 sites are mydomain.com/sitename/ (using sub-folders)

    I can view all four sites just fine, however only the images in my sub-sites work, the sites using the blogs.dir folder for uploads. When I upload images to my first site, the images go to wp-content/uploads/. I can see them using my ftp program, but if I direct to them in my browser, I receive a 404 error. I copied the htaccess code exactly as given so I don’t understand why it is doing this. Could someone help me out please? Thank you!

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    What’s the URL you’re using to try and view them?

    Erica

    (@ericamdion)

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Interestingly http://gutterprosamerica.com/wp-content/uploads/2012/07 is also a 404.

    Is that the complete htaccess? Any caching plugins going on?

    Erica

    (@ericamdion)

    The only plugin I ever activated was the domain mapping plugin. When I discovered the issue, I deactivated the plugin and removed the code from the wp-config file that linked to it. It didn’t seem to fix it. I’m completely baffled.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    And that is your complete htaccess?

    And the folders for uploads exists?

    Erica

    (@ericamdion)

    I double checked my .htaccess file and that is complete. I also verified that every folder in that chain exists, there are even files in the folder so I know that the upload portion is working, thumbnails are successfully created, but when WordPress goes to show them it cannot find it, nor can I through direct linking.

    It is hosted on Godaddy, would this be a problem? Perhaps their default htaccess rules for shared hosting is conflicting? I really have no good ideas here and was hoping you may. The host is the only difference I really have between this and other multi-site installs I’ve used. I’ve even had success with the domain mapping plugin, although I don’t use it for every project.

    GoDaddy does have some odd quirks, and if everything but the host is the same, then I would be suspicious too.

    That said, they do support Multisite on shared hosting (subfolder only, not subdomain) so it should work. You’re not accidently on a Windows server, are you?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Main Site Images 404 Error’ is closed to new replies.