Support » Multisite » Main site access issues with subdomain structure

Main site access issues with subdomain structure

  • Hi,

    The company in which I’m doing my internship asked me to set up locally a WordPress network with this structure:

    http://sitebuilder – Main site
    http://site1.sitebuilder – subsite 1
    http://site2.sitebuilder – subsite 2

    so without .com or whatever..

    I have control on a CentOS server, so I have to deal directly with the Linux server configuration (in which I don’t actually have any experience, as well as the administrator guy who usually deals with Microsoft environments). Consequently, I have control on httpd conf file and such things.

    I’ve been able to set up the whole WordPress network using the structure mentioned and I can access both the network dashboard (sitebuilder/wp-admin) and each subsite dashboard (site1.sitebuilder/wp-admin) using the browser installed on the CentOS server. Unfortunately, I can’t access the network dashboard on other computers in the same company LAN. Yet I’m able to access subsite dashboard.

    Maybe it’s just a matter of Apache configuration, or some DNS stuff, but I don’t know how to sort it out and I have almost no experience on server side.

    Anyway, I was able to get things work with a structure like: sitebuilder.com, site1.sitebuilder.com, etc.. (with .com or whatever)

    Some ideas? Something more I should explain in order to understand my problem?
    Maybe isn’t just possible, I don’t know


Viewing 3 replies - 1 through 3 (of 3 total)
  • Sure, you just need to edit the hosts file to know that http://sitebuilder is a valid alias

    This is 100% internal?

    for time being, it will only work internally in the company network but hopefully they would like to host network sites on their server

    in my hosts file I just added the ip of the server followed by “sitebuilder”

    Ah. You have to manually add in site1.sitebuilder and site2.sitebuilder as well :/

    No way to (easily) do wildcard subdomains locally. You could ask that in the Localhost subforum, though.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Main site access issues with subdomain structure’ is closed to new replies.