Support » Fixing WordPress » Main page and logo link issues

  • I am new to wordpress and any blogging or website design tools. I have almost completed my website, but am having trouble with the main page and page my logo links back to. I created 5 pages, and when I preview the website the main page is a page I did not create and cannot edit. This page also returns when I click on the logo. How can I have the main page be one I created? How can I link the logo to the main page I want it to link to? Thanks for any help!

Viewing 14 replies - 1 through 14 (of 14 total)
  • You need to edit /wp-admin/ >> Settings >> General >> “Front page displays” and choose a post or page to be the frontpage.

    I don’t have “Front page displays” as an option to choose under my general settings.

    I’m not 100% sure, but if your theme has a front-page.php file, it may disable that option. Check in your theme for a front-page.php file and rename it, then try that setting I mentioned again.

    Go to Settings > Reading, not Settings > General. There is a radio button to choose “A static page” and a drop down to choose which page to display. =)

    My bad 🙁

    Don’t worry, I told someone earlier to go to Appearance > Logo to change thier logo instead of to Appearance > Header =P

    I don’t have an option under reading for a radio button choice. All it says on my reading page is:
    Blog pages show at most

    posts

    Syndication feeds show the most recent

    items

    For each article in a feed, show

    For each article in a feed, show
    Full text
    Summary

    Encoding for pages and feeds

    The character encoding of your site (UTF-8 is recommended, if you are adventurous there are some other encodings)

    What theme are you using?

    zeeCorporate

    Ok, it’s not the theme, I just installed it on my dev site and the reading options are there. Can you provide a link to your website? What plugins do you have installed?

    Thank you for your help!

    The website is http://prismpilatesboutique.com. The page it brings you to is the page I did not create (or intend to publish).

    Maybe you can also help me with unpublishing it? It has somehow been published, but I don’t want it to be, considering it isn’t functioning properly yet.

    The only plug-ins I have installed are: Akismet, Select Enhanced Admin Bar with Codex Search, and Hello Dolly. The Enhanced Admin bar is the only theme that is active at this time.

    One other thing, I am using version 1.2, not sure if that makes a difference or not?

    It’s not a published page exactly. WordPress has a default way of displaying the home page. Generally it displays posts on the front of the site by default. But then under Settings > Reading there is SUPPOSED to be an option to choose between displaying posts or displaying a static page.

    What happens if you add a post, just toss something in there with a test title and publish it.

    I was able to post a test post and page. After publishing both of those the radio button you described appeared. Thank you so much for all of your help. Appreciate it!!!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Main page and logo link issues’ is closed to new replies.