WordPress.org

Forums

Main navigation dropdown menus fall behind youtube videos (19 posts)

  1. l_raath
    Member
    Posted 3 years ago #

    Hi,

    I am using WP 3.3.1 and latest Mystique theme, Browser Chrome and Firefox.
    After update 3.3.1 update my main navigation menu bar "disappears" behind youtube embedded videos. I use the video url as code only in the post/page html. I tried changing the z-index but this made no difference. I used the &wm=transparent modifier to the youtube videos as well but then it only shows a black frame where the video should be.

    Please help with this

  2. James Edmonston
    Member
    Posted 3 years ago #

    Any chance you can post a link to the site? Will have a look at it.

  3. l_raath
    Member
    Posted 3 years ago #

  4. James Edmonston
    Member
    Posted 3 years ago #

  5. l_raath
    Member
    Posted 3 years ago #

    This link is very old and references "flash" but the youtube videos aren't flash? also do you need to put this in css or use it as a seperate modifier to the youtube url (and how would the url look like as I'm not great with html and css)

    I am after all a physio not web designer. Thanks again for the help

  6. l_raath
    Member
    Posted 3 years ago #

    also when I use the following embed code I just get a blank space

    <iframe width="560" height="315" src="http://www.youtube.com/embed/CE3rJL5DKiE?rel=0" frameborder="0" allowfullscreen></iframe>

    where the video should be

  7. l_raath
    Member
    Posted 3 years ago #

    can anyone help with this please?

  8. Nasir Zia
    Member
    Posted 3 years ago #

    I found the solution here

  9. l_raath
    Member
    Posted 3 years ago #

    as mentioned before, if I use this code EVEN WITH the wmode the video doesn't show! I'm using google chrome

  10. Nasir Zia
    Member
    Posted 3 years ago #

    I hope you have read the whole article.
    The only change you need to do is to add an extra parameter ?wmode=transparent to the src link.

    <iframe width="420" height="345" src="http://www.youtube.com/embed/FF183gRb4sw?wmode=transparent" frameborder="0" allowfullscreen>

    Reference

  11. l_raath
    Member
    Posted 3 years ago #

    yes I did thanks, this didn't solve the problem,

    however I was browsing through my css files and I think I saw the error on the "iframe" embed code, it had a low z-index so i've changed that, i'll try this first and see if it makes a difference.

    thanks again

  12. finxi
    Member
    Posted 3 years ago #

    I have a similar problem, drop down menu looks different in IE9 than Firefox. IE9 is the problem here, The video drop down menu called "building tutorials" is positioned differently in IE9 than firefox, I cannot select "Stage 1 videos", looks like it is under the main menu bar. goto finxi.ca

    thanks

  13. Kamalapaton
    Member
    Posted 3 years ago #

    I tried the ?wmode=transparent to the embedded source code for the iframe and it didn't work either. I'm still struggling to find a solution. I'll check and see what my iframe css is, if I even have it.

  14. Mike
    Member
    Posted 3 years ago #

    same problem here.

  15. Mike
    Member
    Posted 3 years ago #

  16. dartiss
    Member
    Posted 3 years ago #

    Artiss YouTube Embed has an option to specifying the windowing method, as per the mikedark solution.

    David.

  17. mjmahsan
    Member
    Posted 3 years ago #

    HI
    CAN U HELP ME TO Main navigation CHGE THE CLOUR HOW CAN I AD IT FROM DOWN
    /* =Menu
    -------------------------------------------------------------- */

    #access {
    background:#ffffff;
    display: block;
    float: left;
    margin: 0 auto;
    width: 940px;

  18. Murtaza Frosh
    Member
    Posted 2 years ago #

    Guys;

    Using &wmode=transparent instead of ?wmode=transparent worked for me

    Regards
    Murtaza Frosh
    Maimoon Inc.

  19. Murtaza Frosh
    Member
    Posted 2 years ago #

    I just found out that if you're using ?rel=0 in your link to disable and related videos to show up at the end of your video clip the ?wmode=transparent does not work. In that case you need to use &wmode=transparent & also make sure its inserted after ?rel=0

    Regards
    Murtaza Frosh
    Maimoon Inc.

Topic Closed

This topic has been closed to new replies.

About this Topic