Support » Fixing WordPress » Main menu not working

  • krisdysert

    (@krisdysert)


    I created this site yesterday, and have disabled plug-ins. I am new to WP, so this may be basic.

    I have created a couple of pages, which have automatically appeared in the header menu. The links don’t work – why?

    onesixonestl.com

Viewing 7 replies - 1 through 7 (of 7 total)
  • tomontoast

    (@tomontoast)

    Your permalink structure is not working probably due to a missing .htaccess file see http://codex.wordpress.org/Using_Permalinks

    rfair404

    (@rfair404)

    to follow up on tomontoast’s comment, in the Admin go to Settings > Permalinks and set them to the default. See if the links work then? If not can you post the url’s to your homepage and the broken links?

    krisdysert

    (@krisdysert)

    Even if I paste in the link, the page is not there.

    Edit Page Add New
    Enter title here
    Permalink: http://www.onesixonestl.com/about/ ‎Edit View Page

    It acts as if it created the page there, but it didn’t. Where is the page?

    Also, if I “Preview” the page, I get a 404.

    krisdysert

    (@krisdysert)

    I changed the permalinks back to default and can now find the page. I guess it says it created it with a post name, but didn’t?

    krisdysert

    (@krisdysert)

    One more question: if you visit

    http://www.onesixonestl.com/?page_id=19

    and click the picture, you get another 404. Ideas?

    Thanks all, I appreciate the quick help!

    tomontoast

    (@tomontoast)

    You need to edit the picture link on that page to get rid of the incorrect link which still assumes permalinks.

    krisdysert

    (@krisdysert)

    Gotcha – thanks again!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Main menu not working’ is closed to new replies.