Support » Fixing WordPress » Main editing box can't work after WordPress 4.2.2 installed

  • Resolved ralphdeng

    (@ralphdeng)


    Hi,

    After installed WP 4.2.2, the toolbar of main editing box is disappear and the content is needed to be selected to show. You can see the screenshot below.

    Please help. Thank you!

Viewing 15 replies - 1 through 15 (of 16 total)
  • I mean the main editing box in both of Posts and Pages.
    http://sinyieach.com.tw/wp-content/uploads/2015/05/wp-error050701.png

    4.2.1 is okay. The error happens after updated to 4.2.2.

    I have the same issue and have tried turning off all plug-ins and clearing the browser cache.
    I went back to version 4.0 and now have a fully working editor

    This may be one or few of your plugins and themes are not compatible with 4.2.2. Try to deactivate them to figure out whether things are resolved.

    Thanks wapphotography & PHPMatters. I don’t have install any plugins and just one theme called Divi.

    I guess the issue comes from some Visual Editor(TinyMCE) vulnerability is fixed from the information below.
    https://codex.wordpress.org/Version_4.2.2

    Ha! I know how to fix. You can try http://(your domain)/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=4109-20150505

    If it returns 403 Forbidden HTTP status code, you need to open the execution permission of wp-tinymce.php to make main editing box workable.

    Ralph I followed your instruction on a site running 4.2.2 and get all of the php code for tinymce so guess the problem is elsewhere

    i have the same isse and the above solution didn’t work…any idea?

    fixed adding

    define( ‘CONCATENATE_SCRIPTS’, false );

    in wp-config.php

    Thanks, Darietto! Your fix worked!

    I can’t see or change any copy in my visual editor, no matter which fix (above) I try.

    As a result, I can’t edit or add posts or pages.

    Does anyone here actually work for WordPress? Is this a known bug?

    I tried adding define( ‘CONCATENATE_SCRIPTS’, false ); to the wp-config.php and it didn’t work for me. Is there a specific place within the file it needs to go? Do I then need to log out and back in to get the update?

    I tried that, too.

    Here’s what else I’ve tried:

    1. Turning off plugins via phpmyadmin
    2. Reinstalling 4.2.2
    3. Changing themes
    4. Reinstalling the theme

    My next task is to do a fresh WP installation in a new directory. Then, I’ll move my wp-content file into the directory and reconnect the SQL database.

    Just fixed bug for me.

    You need to update TinyMCE (wp-include/js/tinymce.min.js) to 4.1.10 – just download it from official site.

    Issue discovered today, yesterday everything works fine… I updated to 4.2.2 some time ago.

    SCREENSHOT:
    https://docs.google.com/file/d/0B92OgSEGXPrrT25mMUdsdnkyeGM/edit?usp=drivesdk

    Tried this:

    1) All plugins disabled
    2) Activating Twenty Fifteen theme
    3) Reinstalling 4.2.2 from backoffice and FTP
    4) Adding wp-config.php define(‘CONCATENATE_SCRIPTS’, false);
    5) Adding wp-config.php define(‘SCRIPT_DEBUG’, false);
    6) Updating tinymce.min.js to 4.1.10
    7) Tried multiple browers and multiple computer (from other co-workers)

    Any other idea? We are on a 900.000 pageviews per month site and cant allow site downtimes for writers…

    Regards,

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Main editing box can't work after WordPress 4.2.2 installed’ is closed to new replies.