Support » Fixing WordPress » main directories all have fatal errors! hosed.

  • Resolved dss


    I was moved by my host to an isolated server because they keep telling me that when anyone loads the wp-admin/ppost-new.php that it’s crashing the server.

    So they moved me to an isolated spot to try and prove this.

    Once moved, only WordPress installations on the innermost subdirectory will work.


    any instal attempting to coexist with a sub installation get’s this error:

    Warning: require(/home/imperial/public_html/imperialdub/wp-content/advanced-cache.php) [function.require]: failed to open stream: No such file or directory in /home/imperial/public_html/imperialdub/wp-settings.php on line 84
    Fatal error: require() [function.require]: Failed opening required '/home/imperial/public_html/imperialdub/wp-content/advanced-cache.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/imperial/public_html/imperialdub/wp-settings.php on line 84

    I realize this says that there’s trouble locating the advanced-cache.php alias which the new version of wordpress creates.

    the problem was really that I couldn’t get to the backend of the main wordpress installations to even look at it.

    domain/wp-admin simply reports the same error. every page shows the same error.

    So I removed one main install. Dropped the database tables, reomved all the wordpress files, and simply put up an index.html

    still, nothing from the root directory loads. only the error reports.

    I see this error posted throughout the support section, sometimes repointing to the absolute path works to ficx it (not for me) and sometimes deactivating plugins fixed it (nothing activated here)

    What is this?

    My host is not being helpful at all, even though they appear to have caused this (everything was just fine before)

    And there’s no solution posted here.

    I’ve got a lot of wordpress within wordpress installations, and they are all broken right now.

    kind of in a panic.

    please help.

Viewing 6 replies - 1 through 6 (of 6 total)
  • whooami



    “…failed opening required ‘/home/imperial/public_html/imperialdub/wp-content/advanced-cache.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/imperial/public_html/imperialdub/wp-settings.php on line 84

    I realize this says that there’s trouble locating the advanced-cache.php alias”

    Thats not an aliased file its looking for. Its looking for the file. Follow the path and put the file there.

    The WordPress root of your site is imperialdub .. you need to make sure that your files are where they belong.

    They appear to be correct.

    I have actually reloaded and run the upgrade script again on the subdomains and the issue remains.

    However, to my host’s credit, they have fixed one of the two main issues. They say that there are symbolic links within the domains which were not restored correctly (and I’m not sure what that means) but they’ve fixed my site:
    which uses a sub directory /test/ for testing in relative private

    they say they did this by deleting and re creating the symbolic link.

    I’ve asked them for clarification, and to please do the same for the other sites having this problem.

    I still don’t really understand what’s happened here.




    Google symlink.

    From Wikipedia:

    In computing, a symbolic link (often shortened to symlink and also known as a soft link) consists of a special type of file that serves as a reference to another file or directory. Unix-like operating systems in particular often feature symbolic links.
    Unlike a hard link, a symbolic link does not point directly to data, but merely contains a symbolic path which an operating system uses to identify a hard link (or another symbolic link). Thus, when a user removes a symbolic link, the file to which it pointed remains unaffected. (In contrast, the removal of a hard link will result in the removal of the file if that file has no other hard links.) Systems can use symbolic links to refer to files even on other mounted file systems. The term orphan refers to a symbolic link whose target does not exist.
    Symbolic links operate transparently, which means that their implementation remains invisible to applications. When a program opens, reads, or writes a symbolic link, the operating system will automatically redirect the relevant action to the target of the symlink. However, functions do exist to detect symbolic links so that applications may find and manipulate them.
    Users should pay careful attention to the maintenance of symbolic links. Unlike hard links, if the target of a symbolic link is removed, the data vanishes and all links to it become orphans. Conversely, removing a symbolic link has no effect on its target.

    So this is a hosting issue? Not a WordPress error?




    yes it is. they moved your files, they used symlinks to point to the old location(s) (maybe, I dont know or care) of the files. This has NOTHING to do with WP. wordpress does NOT use or make ANY symlinks.


    thank you.

    it’s important in an instance where the host is expressing that wordpress is causing all kinds of problems to be able to understand what they are saying.

    I really appreciate your help.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘main directories all have fatal errors! hosed.’ is closed to new replies.