Main Area of website my posts messages are all on one line (3 posts)

  1. gauthier613
    Posted 2 years ago #

    cross post from http://wordpress.org/support/topic/main-area-of-website-my-posts-messages-are-all-on-one-line?replies=1#post-4249129

    On the main page all the text is on one line. I have TinyMCE Advanced Plug in on and tried to turn it on and off but they text is all combined.

    Could anyone help determine why this only happens on the main page? If you click the post its OK though.

    I heard some talk that maybe my Line Height in my CSS code could be wrong but cannot not seem to find the reference.

    BR Tags are being used.

    Website is Radiowall.com

  2. CrouchingBruin
    Posted 2 years ago #

    The posts on the main page all run together because WordPress strips out all of the formatting tags for excerpts. So if you are displaying excerpts on the main page instead of full posts, you will see the "run-on," unformatted lines. I've heard that this is standard practice with WordPress; because the excerpt function extracts a certain number of words from the main post, it can't be sure that it will miss a closing tag and cause problems with the whole page. For example, if you set the excerpt function to return the first 55 words, and in that first 55 words there's an opening DIV tag, and the closing /DIV doesn't happen until after the 100th word, then that opening DIV tag can mess up the rest of the page. There are certain plugins that you can install that will retain the formatting for an excerpt, just do a Google search on WordPress excerpt formatting plugin.

  3. CrouchingBruin
    Posted 2 years ago #

    Another way to get around it is to substitute bfa_excerpt in the postformat.php subtemplate page with the_excerpt(). the_excerpt() will use the Excerpt field, and you can use a limited subset of HTML in the Excerpt field of your post. Go to your Post Editor, and the Excerpt field should be underneath. If you don't see the Excerpt field, then click on the gray Screen Options tab in the upper right corner and check Excerpt. It should then appear.

    The only downside is that you will now see two read more links, one from the_excerpt() and the other that's coded within postformat.php. You can hide the former by adding this to your post.css option page:

    .post-bodycopy .post-readmore {
      	display:		none;

    Or, if you want to get rid of the latter, just delete it from your postformat.php option page.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic


No tags yet.