Support » Theme: emulsion » mailto links do not work

  • Resolved sbliudze

    (@sbliudze)


    Hello,

    It appears that the ‘mailto:’ links (alongside some other types) are disabled in the theme. Here is the relevant piece from the CSS (recovered through Element Inspector in Firefox):

    .link-disabled, a[href^="mailto:"], a[href^="geo:"], a[href^="sms:"], a[href^="tel:"] {
        pointer-events: none;
        cursor: default;
        text-decoration: none;
    }

    I cannot find where this is parameterised and how can I fix it properly. Any help would be appreciated.

    • This topic was modified 4 months ago by sbliudze.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Theme Author nobita

    (@nobita)

    Hi @sbliudze

    You can create the following types of links in Appearance / Menu, but in the emulsion theme these link types are set to work only on mobile devices.

    mailto:,geo:,sms:,tel:

    The easiest way to change this setting is to overwrite the CSS.

    example

    Appearance / Customize /

    Additional CSS

    paste style rules

    
    #document a[href^="mailto:"],
    #document a[href^="geo:"],
    #document a[href^="sms:"],
    #document a[href^="tel:"]{
        pointer-events:auto;
        cursor: pointer;
        display:inline-block;
    }
    

    Here is where the style is defined

    https://github.com/tenman/emulsion/blob/master/source/scss/_elements.scss#L14-L22

    Since this file is an SCSS file, it will not be reflected if you change it directly.

    Thank you.

    Thread Starter sbliudze

    (@sbliudze)

    Thanks for your quick reply @nobita!
    Ok, I’ll go with the additional CSS then.
    Best regards,
    Simon

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.