Support » Plugin: Mailster WordPress Newsletter Plugin Compatibility Tester » Mailster AWS SES Integration Signature version 3 Error

  • Resolved reyanshkharga

    (@reyanshkharga)


    Hi,

    I have been using the plugin for long and it is working all fine but recently I received this mail from AWS stating I’m using signature 3 for AWS and I need to change it to signature version 4. I don’t know what to do.

    I am using mailster v2.4.

    Here’s the email from AWS.
    ———————————-

    Amazon Simple Email Service (SES) had extended support for Signature Version 3 to February 28th, 2021. To continue to use Amazon SES, you must migrate to Signature Version 4 which offers enhanced security for authentication and authorization of Amazon SES customers.

    We have identified that, between 2021-05-03 and 2021-05-10, your AWS account 174228166529 used Signature Version 3 to call Amazon SES APIs in the us-east-1 Region.

    Your Signature Version 3 requests were identified to be originating from:
    – IAM Users: arn:aws:iam::174228166529:user/KOSA
    – IPs: 162.144.20.85
    – User Agents: WordPress/5.7.1; https://saahm.net

    Your Signature Version 3 requests were identified to be using the following SES actions:
    – APIs: VerifyEmailIdentity, GetSendQuota, SendRawEmail, ListIdentities

    Example Request ID using Signature Version 3: a1fa9ff2-b7f1-4ce8-9afe-3a3843c2ad5a

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author EverPress

    (@everpress)

    Hey There,

    Thank you for writing in! We provide all of our official support via the member area on our website. If you have not done so yet, please use the link below to register for access so that you can post your question there: https://mailster.co/go/register/

    We are looking forward helping you out.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.