Support » Plugin: WP Mail SMTP by WPForms » Mails not being sent anymore

  • Resolved ngranko

    (@ngranko)


    After updating the plugin to 0.11.1 emails are not being sent anymore. I have the “Send all WordPress emails via SMTP” option selected, but in the test output I see that it tries to send mail as “root@localhost”, which looks more like something the standard mail() function would use. The test output is:

    PHPMailer Object
    (
    [Version] => 5.2.22
    [Priority] =>
    [CharSet] => iso-8859-1
    [ContentType] => text/plain
    [Encoding] => 8bit
    [ErrorInfo] => Invalid address: (setFrom) wordpress@
    [From] => root@localhost
    [FromName] => Root User
    [Sender] =>
    [ReturnPath] =>
    [Subject] =>
    [Body] =>
    [AltBody] =>
    [Ical] =>
    [MIMEBody:protected] =>
    [MIMEHeader:protected] =>
    [mailHeader:protected] =>
    [WordWrap] => 0
    [Mailer] => mail
    [Sendmail] => /usr/sbin/sendmail
    [UseSendmailOptions] => 1
    [PluginDir] =>
    [ConfirmReadingTo] =>
    [Hostname] =>
    [MessageID] =>
    [MessageDate] =>
    [Host] => localhost
    [Port] => 25
    [Helo] =>
    [SMTPSecure] =>
    [SMTPAutoTLS] => 1
    [SMTPAuth] =>
    [SMTPOptions] => Array
    (
    )

    [Username] =>
    [Password] =>
    [AuthType] =>
    [Realm] =>
    [Workstation] =>
    [Timeout] => 300
    [SMTPDebug] => 0
    [Debugoutput] => echo
    [SMTPKeepAlive] =>
    [SingleTo] =>
    [SingleToArray] => Array
    (
    )

    [do_verp] =>
    [AllowEmpty] =>
    [LE] =>

    [DKIM_selector] =>
    [DKIM_identity] =>
    [DKIM_passphrase] =>
    [DKIM_domain] =>
    [DKIM_private] =>
    [DKIM_private_string] =>
    [action_function] =>
    [XMailer] =>
    [smtp:protected] =>
    [to:protected] => Array
    (
    )

    [cc:protected] => Array
    (
    )

    [bcc:protected] => Array
    (
    )

    [ReplyTo:protected] => Array
    (
    )

    [all_recipients:protected] => Array
    (
    )

    [RecipientsQueue:protected] => Array
    (
    )

    [ReplyToQueue:protected] => Array
    (
    )

    [attachment:protected] => Array
    (
    )

    [CustomHeader:protected] => Array
    (
    )

    [lastMessageID:protected] =>
    [message_type:protected] =>
    [boundary:protected] => Array
    (
    )

    [language:protected] => Array
    (
    [authenticate] => SMTP Error: Could not authenticate.
    [connect_host] => SMTP Error: Could not connect to SMTP host.
    [data_not_accepted] => SMTP Error: data not accepted.
    [empty_message] => Message body empty
    [encoding] => Unknown encoding:
    [execute] => Could not execute:
    [file_access] => Could not access file:
    [file_open] => File Error: Could not open file:
    [from_failed] => The following From address failed:
    [instantiate] => Could not instantiate mail function.
    [invalid_address] => Invalid address:
    [mailer_not_supported] => mailer is not supported.
    [provide_address] => You must provide at least one recipient email address.
    [recipients_failed] => SMTP Error: The following recipients failed:
    [signing] => Signing Error:
    [smtp_connect_failed] => SMTP connect() failed.
    [smtp_error] => SMTP server error:
    [variable_set] => Cannot set or reset variable:
    [extension_missing] => Extension missing:
    )

    [error_count:protected] => 1
    [sign_cert_file:protected] =>
    [sign_key_file:protected] =>
    [sign_extracerts_file:protected] =>
    [sign_key_pass:protected] =>
    [exceptions:protected] => 1
    [uniqueid:protected] =>
    )

    I didn’t make any changes to the plugin settings prior to it starting to fail, the same config worked before. I had updated the plugin itself to version 0.11.1 and the WordPress itself to 4.9 at the same time, though, so that might have something to do with it. Since the problem started I updated the plugin to 0.11.2 and tried to link another account to it, but the error hasn’t changed.

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Mails not being sent anymore’ is closed to new replies.