Support » Plugin: MailPoet - emails and newsletters in WordPress » mailpoet_archive display only date

  • Resolved biegstal

    (@biegstal)


    The archive does not show all newsletters. I have manually added the newsletters on the page, and underneath via [mailpoet_archive]. The date is visible, but only one newsletter.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author MailPoet

    (@wysija)

    You can allow more lists on the Settings page, this way, more newsletters will appear: https://beta.docs.mailpoet.com/article/217-display-a-list-of-past-newsletters-on-a-page

    biegstal

    (@biegstal)

    After adding content to functions.php the website gives Error 500.
    If you look at the page https://hetbrandpunt.net/nieuwsbrief-archief/ it look likes there is random added newsletters.

    I have the same problem as you : THe shortcode shows only the date of each newsletter and not the name of the newsletter.
    Thanks for your help.
    Alain.
    mel adress : alain.beaude@wanadoo.fr

    Hey biegstal, looks like you solved it, but how?
    I can’t get the shortcode to list ANY newsletters after the date (I must admit, we have only sent one so far, but that’s not showing either). See https://www.rosa-zaanstad.nl/nieuwsbrief-archief/
    Restricting it in the settings to only one newsletterlist did not help either…

    thanks in advance,

    Peter

    • This reply was modified 1 year, 9 months ago by ikookmaar.

    Hi
    Does the problem still exist ?
    regards

    Hi everyone,

    I find I am having the same problem, and it started yesterday when I did one thing–I edited newsletters I had already sent. See here:

    https://stbenedict.wcdsb.ca/about-us/benn-newsletter/

    When I go to “view source” the A href tag is there, but the text that should appear on the screen does not do so.

    I thought I’d try to “resend” the newsletter to a second list to see if that would do something but it wouldn’t let me (said it would be considered spam).

    I wonder if any of you are encountering this problem after editing after sending?

    Well. Looks like the problem that I experienced myself.
    It’s possible that I edited the newsletters. I’m not sure.
    I unfortunately got rid of the functionality until any good solution is provided, if any.
    Regards

    I’m having the same issue. From what I can gather from my archive, the ones with just a date and no link are dates when I created a newsletter, or updated one, but didn’t send it.

    So, I have March 25, 2018 showing but no newsletter link. That day I created a newsletter and saved it, but didn’t send it. If I view the source I can see it’s the newsletter that I did send the following day. March 26, 2018 has a proper link to the newsletter since that’s the day it was actually sent.

    This seems to hold up when I look at my other dates with no newsletter link.

    Looks like MailPoet has a bug they need to fix so it only pulls dates when a newsletter was sent, not created or updated.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘mailpoet_archive display only date’ is closed to new replies.