Support » Plugin: Add-on Contact Form 7 - MailPoet 3 » Mailpoet producing linebreaks

  • mrmcx

    (@mrmcx)


    When I use the following shortcode in a contact form, there are some <br>’s produced that shouldn’t be there. Can you tell me why?
    Shortcode:
    [mailpoetsignup* mailpoetsignup list:4 "Gelesen und verstanden!*"]

    HTML:

    <p>
    <span class="wpcf7-form-control-wrap mailpoetsignup">
    <br/>
    <span class="wpcf7-form-control wpcf7-mailpoetsignup wpcf7-validates-as-required">
    <br/>
    <input type="checkbox" name="mailpoetsignup" value="4" id="mailpoetsignup"/>
    <br/>
    </span>
    <br/>
    <label for="mailpoetsignup">Gelesen und verstanden!*</label>
    <br/>
    </span>
    </p>

    Thank you!

    • This topic was modified 2 years ago by mrmcx.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • mrmcx

    (@mrmcx)

    I fixed it with

    .wpcf7-form-control-wrap.mailpoetsignup br {
        display: none;
    }

    but this should not be a final solution IMHO

    Plugin Author ehsantikweb

    (@ehsantikweb)

    Hi @mrmcx,
    I see that the <br>’s produced in your given link, that shouldn’t be there, I used the same shortcode [mailpoetsignup* mailpoetsignup list:4 "Gelesen und verstanden!*"] on our site, no < br >’s are there.
    Here is site link

    Did you make any changes yourself?

    Thanks

    mrmcx

    (@mrmcx)

    I didn’t change anything in the plugin or the CF7 plugin.

    tamim71

    (@tamim71)

    hi @mrmcx, you can remove current shortcode and re create new shortcode again see if it still produce line breaks.

    mrmcx

    (@mrmcx)

    Yes it does…
    I also tried different settings (auto on, other list etc.) but that didn’t change anything

    Plugin Author ehsantikweb

    (@ehsantikweb)

    Hi @mrmcx,
    Could you please deactivate all the plugins except the required plugins and then activate the default WP theme instead of your custom theme? Let me know if you still have the same issue.

    Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Mailpoet producing linebreaks’ is closed to new replies.