Support » Plugin: MailPoet - emails and newsletters in WordPress » MailPoet Database Tables Are Getting Huge!

  • Resolved supertrooper2

    (@supertrooper2)


    The size of our database has increased dramatically because of MailPoet. The individual tables now account for almost 1GB, the largest being mailpoet_scheduled_task_subscribers, wp_mailpoet_statistics_newsletters, wp_mailpoet_statistics_opens, wp_mailpoet_statistics_clicks and wp_mailpoet_newsletters.

    Do we really need to keep all of these records and statistics in the database?

    Is there any way to reduce the overall size of the tables in the database?

    Please advise.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author MailPoet

    (@wysija)

    Hi there @supertrooper2,

    Those tables you mention contain important subscriber information about the newsletter. If you delete the data in wp_mailpoet_statistics_newsletters (including the clicks and opens tables also), in your wp-admin > MailPoet > Emails you’ll notice that the stats will be missing for the affected newsletters.

    If you delete the data in wp_mailpoet_newsletters, you’ll be deleting the newsletters themselves and then they won’t show in your wp-admin > MailPoet > Emails.

    If you have old newsletters that you don’t mind if you can or can’t see the opens/clicks, then you can safely the data associated with those older newsletters.

    Thanks!

    I’m sure that many MailPoet users have “bloated” databases caused by the MailPoet plugin. In my case the MailPoet statistics tables were almost 1GB, and making a backup of the website was practically impossible due to the size of the database!

    There should be an option on the settings page to delete lines in the statistics tables older than 1 month, 3 months, 1 years, etc.

    It should not be necessary to have to start messing about in the database tables.

    This can be quite risky even for WordPress professionals.

    Urgently awaiting a fix for this issue!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.