Support » Plugin: MailPoet - emails and newsletters in WordPress » Mailpoet and Google Captcha not working

  • Resolved jason1995

    (@jason1995)


    Dear support,

    We have problems with getting your Captcha options to work. First we tried the mailpoet plugin option. However, the Captcha image was not showing, so users got stuck. I found your article about the functions.php but we were not able to get it to work.

    So we switched to Google Captcha, unfortunately that didn’t fully work either. Although it seems to work on Google Chrome, other browsers are again not showing the image, it stays on the same page saying ”please check the CAPTCHA”.

    So now we turned it off, which is of course not preferred. So kindly could you help us out here? Much obliged,

    Jason

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support dromero20

    (@dromero20)

    Hi!

    I’d like to take a further look into it. Could you please enable the built-in MaiPoet Captcha and share a link to a page of your website where the form is added? So we can check from our end how it renders.

    Thread Starter jason1995

    (@jason1995)

    Hey thanks so much for your quick reply!
    Yes, you can go to https://lumisoul.fi
    At the bottom of th epage in the footer, you can subscribe. (Liity Sähköpostilistalle!)
    I just updated to your latest version and it makes no difference unfortunately.

    Thanks so much for your help.

    Jason

    Thread Starter jason1995

    (@jason1995)

    @dromero20 Hey, any updates yet? 🙂 Since with the setting on, the mail optin is not working, so I feel slightly uncomfortable. I try to be patient though, thanks so much for your help!

    Plugin Support Elvira K

    (@treibalen)

    Hi there @jason1995,

    Indeed, we do have a bug reported that Google reCAPTCHA 2.0 is only displayed in Chrome.

    While we’re working on a permanent fix, can you please try this fix? https://toolset.com/errata/cred-1-9-2-1-types-2-2-17-18-showstopper-when-using-cred-forms-with-recaptcha/

    Cheers!

    Thread Starter jason1995

    (@jason1995)

    Hi Elvira,

    Unfortunately the snippet makes no difference. I selected google Captcha and used Firefox.

    Now I put the site back to Mailpoet reCaptcha, as your team asked yesterday, but that is also not showing.

    Any news on that, please?

    Thanks so much, Jason

    Plugin Support dromero20

    (@dromero20)

    Hi!

    I took a further look into the console errors while loading the captcha in Chrome and I can see that the custom.unified.js.map is not loading in Divi:

    https://d.pr/i/AZa3TU

    I wonder if that’s the reason why the captcha is not loading either in Chrome.

    Could you please do a conflict test? I’d like you to temporarily switch your theme to a default one (like TwentyTwenty) and turn off all your plugins except for MailPoet.

    Check the captcha and, If that resolves the issue, then one-by-one you can switch back your theme and re-enable your plugins, testing in between, until you find the one causing the conflict.

    That way we can be sure this is not provoked by the Theme or by another plugin preventing the resourced to load.

    Please let us know about the results.

    Thread Starter jason1995

    (@jason1995)

    Hi, thanks so much for helping us out so far.
    The custom.unified.js.map has been giving multiple issues with our caching plugin. So we exclude it with a rule. When I stopped the exclusion:

    1) Mailpoet captcha still not worked
    2) google captcha started working

    Now to add to the mystery, after adding the exclusion again to our caching plugin. Google captcha kept working….. on all browsers

    Mailpoet Built in Captcha is still not showing the image. So the urgency is gone for us, however, if we can be of assistance to get this bug out of your system, we are of course willing to assist.

    Cheers,

    Jason

    Plugin Support Elvira K

    (@treibalen)

    Hi there @jason1995,

    Now to add to the mystery, after adding the exclusion again to our caching plugin. Google captcha kept working….. on all browsers

    It seems like there was an issue with caching and Google reCAPTCHA. That also might be a reason why it didn’t start working with a snippet, but now it works.

    Mailpoet Built in Captcha is still not showing the image.

    I can’t replicate that on my test site so I assume it can be a conflict, as @dromero20 suggested earlier. To confirm that, you can do a full conflict test per steps he outlined.

    Hope it helps, please let us know if you need further assistance!

    Plugin Contributor MailPoet

    (@mailpoet)

    Hi there @jason1995,

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.