Support » Plugin: Subscribe2 » Mailing works, new subscriptions don't since upgrade

  • Resolved nitramtheugly

    (@nitramtheugly)


    Subscribe2 is awesome, I’ve been using it for several years now without issue.

    I just upgraded to WP 3.5 and went ahead and upgraded subscribe2 while I was at it.

    I’m actually not entirely sure when subscribe2 stopped working, although I was getting subscriptions as recently as 2 weeks ago. But, just in case the upgrade is a red herring, I thought I’d throw that out.

    Basically, the subscribe widget and the post page quite working. I get:

    Sorry, there seems to be an error on the server. Please try again later.

    I can send test emails just fine.

    I changed the shortcode, as I was using the old version previously, but that didn’t help either.

    Any ideas on where to look?

    http://wordpress.org/extend/plugins/subscribe2/

Viewing 12 replies - 1 through 12 (of 12 total)
  • @nitramtheugly,

    One thing you could look at is the ‘Sender’ as selected in the Subscribe2->Settings page.

    I’m guessing, but I suspect you have “Post Author” selected. When you are logged in to make a post it probably works fine as the email address in your WordPress profile is on the same domain as your blog.

    However, when you are not logged in (such as when a new user tries to subscribe) the plugin may be searching for an email address and pulling in the first administrator account it can find which may have an off domain email address.

    So, try changing that setting to a WordPress admin level account that you know uses an on-domain email address.

    Thanks so much for taking the time to reply. You were correct that I had it set to from post author and that the post author doesn’t necessarily have a domain address. However making the change doesn’t fix the issue, unfortunately.

    The form doesn’t let you subscribe at all.

    @nitramtheugly,

    When you changed that setting, what did you change it to?

    Was it the name of a user account or the name of your blog?

    @mattyrob,

    I changed it to my account, of which the domain of the email address is same as the site.

    Perhaps you have a debug version I could run to spit out a bit more information?

    I’m sorry to take up so much of your time.

    I went through looking at my subscribers, and my last successful subscription was on the same day I did the upgrade, so perhaps it is related.

    @nitramtheugly,

    You could try installing an email logging plugin, that might help check if the email functions are being called. Either of these:

    http://wordpress.org/extend/plugins/email-log/

    http://wordpress.org/extend/plugins/wp-mail-log/

    Could you post a link to your site so I can have a look at the front side at least?

    Hi Matt,

    The logging did nothing, but I finally had some time to dig into this a bit further and turned on WP logging.

    I found something interesting. It seems as though something changed between schemas in the database table between upgrades of the plugin or wp.

    WordPress database error: [Unknown column ‘time’ in ‘field list’]
    INSERT INTO wp_062tey_subscribe2 (email, active, date, time, ip) VALUES (‘XXXXX@YYYYY.com’, 0, CURDATE(), CURTIME(), ‘98.165.72.205’)

    Looking at the db, here are the fields in the table:
    id, email, active, date, ip, conf_date, conf_time, conf_ip

    @nitramtheugly,

    Great work tracking that down. Can you insert the time column using PHPMyAdmin? It should work then.

    @mattyrob Yup, that’s what I did and it worked. You can close this one out. Thanks for all the help.

    railpass

    (@railpass)

    Ran into the same problem…… same symptoms (Unknown column ‘time’).

    mattyrob

    (@mattyrob)

    @railpass,

    What version of Subscribe2 were you using before the most recent update?

    If you can log into PHPMyAdmin use that to create a new time column in the database.

    railpass

    (@railpass)

    Same fix worked (new field added). My scenario was I migrated from one host to a different host, moving all the files and the sql database as well. Some how that caused me to run into this issue. Running latest versions of S2 and WP – not sure what I was running previously….

    mattyrob

    (@mattyrob)

    @railpass,

    Thanks for following up, glad you got it working but I’m no closer to figuring out why this happens 🙁

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Mailing works, new subscriptions don't since upgrade’ is closed to new replies.