Support » Plugin: Mailgun for WordPress » Mailgun email sending as plain text

  • Resolved zagriyen

    (@zagriyen)


    Hello,
    Mailgun emails sending as plain text, why ?
    how i can correct this please ?

    I try to use mg_mutate_message_body but i don’t know what to do the $boddy[“html”] contain the both plain text and html mixed

    • This topic was modified 1 year, 1 month ago by  zagriyen.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Mailgun

    (@mailgun)

    @zagriyen Can I get more information on your situation (installed plugins, plugin which is sending mail that you expect to be HTML, Mailgun plugin version)? WordPress emails (ie., comment notifications, password resets) will send as plain text always, but other plugins, such as Ninja Forms, will send as HTML.

    @mailgun, I use the mailgun plugin 1.5.8.2, with Gravityforms 2.2
    I send a custom notification when a form completed
    I passed an HTML template with the gform_notification filter.
    In my mu-plugins i have this to set html wp_mail_content_type

    add_filter( 'wp_mail_content_type', 'set_html_content_type' );
    function set_html_content_type() {
    	return 'text/html';
    }
    Plugin Author Mailgun

    (@mailgun)

    @zagriyen Are you sending with SMTP or API? There is a slight incongruity between the SMTP and API sender modules in the plugin.

    @mailgun sending with the wp_mail, in the plugin the setting is “Use HTTP API YES”

    the bug appeared when i started to use a full html template, with partial code like ‘strong’ nothing happened

    The problem was solved with the latest gravityforms version 2.2.1

    Gravity Forms v2.2.1 Changelog
    – Added filter to allow email TO formatting to be turned on or off. Defaults to off.
    – Updated email format so that it defaults to html instead of multipart.
    – Fixed a typo in the notification From header.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Mailgun email sending as plain text’ is closed to new replies.