Support » Plugin: WP Mail SMTP by WPForms » MailGun – deprecation of TLS v1.0 and 1.1

  • Resolved Joe

    (@joewa1980)


    We’ve been using this plugin for some time with MailGun – love it!

    All our other sending methods via MailGun use an SSL connection, but we received this notification from them today and wondered if it is your plugin that’s using TLS to send messages rather than SSL?

    Deprecation of TLS v1.0 and 1.1 
    We've detected that your account is using an outdated and vulnerable version of TLS to send messages. Mailgun will be removing support for these versions on January 15, 2020. 
    
    You will be unable to send messages on or after January 15, 2021 if no action is taken.
Viewing 10 replies - 1 through 10 (of 10 total)
  • I have the same question re deprecation of TLS v1.0 and 1.1 with Mailgun. have you guys upgraded to 1.2?

    Thanks,
    Jason

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi Joe and Jason,

    our Mailgun mailer is using the Mailgun API to send messages to their system using the HTTPS protocol. It does not specify which TLS version to use. That’s something that your environment (server) is responsible for. I think you should contact your hosting support and ask them to update TLS to v1.2.

    More information can be found here:
    https://www.mailgun.com/blog/tls-version-1-0-and-1-1-deprecation/
    https://www.mailgun.com/blog/tls-connection-control/

    Have a nice day!

    Thread Starter Joe

    (@joewa1980)

    Thanks @capuderg – I wasn’t sure if the plugin was affecting the sending, so I appreciate you ruling that out.

    We’ve now dug into our Apache Configuration and although the default with our version (v92.0.7) is now TLSv1.2 it had not actually been selected as the default, so we’re now running TLSv1.2 and will be compliant with MailGun’s new measures.

    @jasonhayward This is labeled as SSL/TLS Protocols in Global Configuration in your Apache Configuration in WHM.

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi Joe,

    no problem and thank you very much for sharing the details with others 🙂

    Have a nice day!

    Thanks @capuderg and @joewa1980,

    FYI (for anybody reading) you can also check the TLS version using – https://www.cdn77.com/tls-test

    Cheers,

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi Jason,

    thanks for sharing this with us. It sure is an easy check 🙂

    Have a nice day!

    Our Mailgun via your plugin also stopped working today after I upgraded to the latest WordPress version. This is from the Test screen log:

    Versions:
    WordPress: 5.7
    WordPress MS: No
    PHP: 7.4.16
    WP Mail SMTP: 2.6.0
    
    Params:
    Mailer: mailgun
    Constants: No
    Api Key / Domain: Yes
    
    Debug:
    Mailer: Mailgun
    Forbidden

    Any ideas?

    Hi @tinuzzo,

    Thanks for the SMTP log. It is likely that your API key isn’t correct for the site you’re using. Please double-check the API and sending domain.

    I hope this helps!

    I am positive this is the correct private API Key used. I just regenerated the MailGun API Key and still the same, this is the output:

    Versions:
    WordPress: 5.7
    WordPress MS: No
    PHP: 7.4.16
    WP Mail SMTP: 2.6.0
    
    Params:
    Mailer: mailgun
    Constants: No
    Api Key / Domain: Yes
    
    Debug:
    Mailer: Mailgun
    Forbidden

    Any ideas?

    Thread Starter Joe

    (@joewa1980)

    Hi @tinuzzo – I would advise you start a new thread as you might attract other users with the same issue. You’re posting this in a resolved thread about TLS v1.1 which has nothing to do with your problem.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘MailGun – deprecation of TLS v1.0 and 1.1’ is closed to new replies.