Support » Plugin: Mailchimp for WooCommerce » Mailchimp+ woocommerce connection problem

  • Resolved touchettev

    (@touchettev)


    The plugin Mailchimp with Woocommerce use to work just fine but not anymore.

    I can not connect my wordpress with my mailchimp account.

    Here is the message I get:

    Mailchimp says: API Request Error – 0 :: on 1862 in /home2/lucieva1/public_html/wp-content/plugins/mailchimp-for-woocommerce/includes/api/class-mailchimp-api.php

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author ryanhungate

    (@ryanhungate)

    @touchettev this sounds like your server may be getting blocked by the Akamai gateway which is a known issue amongst a lot of shared hosting environments. Can you please take a look at this wiki page to see if you can resolve your issue by the troubleshooting methods provided?

    Thread Starter touchettev

    (@touchettev)

    We transferred the serveur and it worked. Thank you!

    Plugin Author ryanhungate

    (@ryanhungate)

    @touchettev awesome – thanks for reporting back. To anyone else that might be coming across this same post, there’s a couple different approaches that would work here.

    1. Adding a dedicated IP address to your machine and telling the plugin to use that ip address. This is a great way to fix that problem and a lot of times could be the easiest and least expensive on time and money and resources.

    2. Switching servers is an option – but not required. You might end up in a similar situation depending on the type of server you’re using or hosting provider. Shared hosting is always prone to this problem. If you’re using “host it yourself” option, those are typically the best ways to avoid this IP address block, because you’re the ONLY site running on that machine. There’s countless options to choose from where you can spin up your own machine, but it’s a tad more advanced for folks to do things that way as it requires migrations, and setting up servers properly.

    Hope that helps, and thanks for the follow up @touchettev – we’ll close this out.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.