Support » Fixing WordPress » MailChimp widget not showing up

  • I’ve had an issue with both themes I’ve tried so I’m not sure this is theme-specific.

    Basically I am trying to get a MailChimp subscribe widget onto a bare-bones site (www.mcfarlandcreativeworks.com) and it either doesn’t show up at all (as in the case of the Hueman theme) or it only shows up for me when I’m logged into WordPress in Chrome…it doesn’t show up in Firefox (where I’m not logged on) or for my husband (on a different computer).

    This is the code (it’s the default code for an Embedded Form which I just copied and pasted from https://us14.admin.mailchimp.com/lists/integration/embeddedcode?id=8727):

    
    <!-- Begin MailChimp Signup Form -->
    <link href="//cdn-images.mailchimp.com/embedcode/classic-10_7.css" rel="stylesheet" type="text/css">
    <style type="text/css">
    	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
    	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
    	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
    </style>
    <div id="mc_embed_signup">
    <form action="//mcfarlandcreativeworks.us14.list-manage.com/subscribe/post?u=b98928858a7d194083e5984dd&id=a760e8d6e0" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
        <div id="mc_embed_signup_scroll">
    	<h2>Subscribe to our mailing list</h2>
    <div class="indicates-required"><span class="asterisk">*</span> indicates required</div>
    <div class="mc-field-group">
    	<label for="mce-EMAIL">Email Address  <span class="asterisk">*</span>
    </label>
    	<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL">
    </div>
    <div class="mc-field-group">
    	<label for="mce-FNAME">First Name </label>
    	<input type="text" value="" name="FNAME" class="" id="mce-FNAME">
    </div>
    <div class="mc-field-group">
    	<label for="mce-LNAME">Last Name </label>
    	<input type="text" value="" name="LNAME" class="" id="mce-LNAME">
    </div>
    	<div id="mce-responses" class="clear">
    		<div class="response" id="mce-error-response" style="display:none"></div>
    		<div class="response" id="mce-success-response" style="display:none"></div>
    	</div>    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
        <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_b98928858a7d194083e5984dd_a760e8d6e0" tabindex="-1" value=""></div>
        <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
        </div>
    </form>
    </div>
    <script type='text/javascript' src='//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js'></script><script type='text/javascript'>(function($) {window.fnames = new Array(); window.ftypes = new Array();fnames[0]='EMAIL';ftypes[0]='email';fnames[1]='FNAME';ftypes[1]='text';fnames[2]='LNAME';ftypes[2]='text';}(jQuery));var $mcj = jQuery.noConflict(true);</script>
    <!--End mc_embed_signup-->
Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi, @lycarland. I’m seeing the MailChimp form on your site right now; so does that mean you were able to get this one resolved?

    Hi @girlieworks I tried a third theme (Dingy) and the MailChimp code did show up. I am not sure why it didn’t show up on Hueman or Twenty Fourteen. Since we are likely going to be changing our theme yet again, it would be nice to know why sometimes it may show up and sometimes not.

    • This reply was modified 3 years, 5 months ago by lycarland. Reason: correction
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘MailChimp widget not showing up’ is closed to new replies.