[resolved] Mailchimp Social 403 errors (7 posts)

  1. adab
    Posted 3 years ago #

    Since I installed your plug-in on my WordPress blog last week, I’ve been getting 403 errors listed by Google Webmasters. This is what I’m seeing:
    I’m not technically minded so don’t know if this is supposed to happen, or if it’s an issue.
    Can you shed any light?


  2. Alex King
    Plugin Contributor

    Posted 3 years ago #

    Sounds like you're perhaps hosting with HostGator, you'll need to ask them to allow this.


  3. jproducer
    Posted 3 years ago #

    Just as an FYI, I am not on hostgator, but hostmonster and I wrote to them and they said they do not do mod_rewrite scripts anymore. What I find more than interesting is that I have several sites on this same exact host and a fresh install of Social plugin worked on another site. My main site which I have been trying to resolve the 403 issue on will not work. Somehow, I'm guessing I need to do a clean install. I have tried to remove all files but there must be something in the DB holding the conflicting information. I just don't see any tables in DB for social specifically. I see some entries in "comment meta" but no standalone tables. So here's my question. How do I perform a truly clean install of the plugin? I think this would resolve my issue.

  4. jproducer
    Posted 3 years ago #

    Just wanted to give an update on this if someone else has the issue and mod_rewrite isn't available. I say DO THIS AT YOUR OWN RISK AND BACKUP YOUR DB FIRST.

    Uninstall Social plugin and delete files.

    Under your (dp-prefix)_options there will be about 18 social_*** table entries. Delete them all.

    Re-install social and voila, no more 403 error and it's a fresh install without killing all your comments and comments meta.

    Worked for me and connected again. I just don't honestly know if FB portion is working again yet, but we'll see.

  5. jproducer
    Posted 3 years ago #

    Unfortunately my issue is back. I was able to get global to connect, and now I'm back to the same issue of not being able to sign in with any account. Have tried even logging in with different usernames and nothing.

    Keep getting below when clicking "connect to facebook" or "connect with twitter"

    Access to the webpage was denied
    You are not authorized to access the webpage at http://fortheloveofpunk.com/wp-admin/index.php?social_controller=auth&social_action=authorize&target=https%3A%2F%2Fsopresto.mailchimp.com%2Ffacebook%2Fauthorize%3Freq_perms%3Dpublish_stream%2Cread_stream%2Coffline_access&use_pages=true. You may need to sign in.
    HTTP Error 403 (Forbidden): The server refused to fulfill the request.
  6. Alex King
    Plugin Contributor

    Posted 3 years ago #

    Talk to your host...

  7. jproducer
    Posted 3 years ago #

    This part of the issue is resolved. A plugin called 6Scan wrote a bunch of entries into my php.ini which was blocking the script.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Social
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic