Support » Plugin: MailChimp List Subscribe Form » mailchimp setting missing

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author mc_nate


    Hey Paul!

    If you don’t mind a little further prying, could you let us know which version of WP you’re running? Additionally, when you say it’s not appearing, do you mean the option itself isn’t showing up under “Settings”, or when you click on it, nothing is loading?

    If you can provide us with the details, we’ll try to replicate things on our end!


    running the latest version of WordPress
    yes, it is the Setting option that doesn’t appear

    Plugin Author mc_nate


    Right on. Thanks for the follow-up, Paul!

    Are you by chance running a WordPress MU installation? We have seen some instances were users (other than the admin) will not be able to find that specific setting. In this case, there was another WP user who suggested editing the PHP for the plugin to support that feature at additional levels:

    Unfortunately, the code isn’t included in that post, but that might help at least get things started on the right path.

    Let us know if we can help with anything else!


    no it’s a regular installation.
    I tried to install it on another site and I have the same problem
    I even disabled all plugins and reset the default theme

    Plugin Author mc_nate


    Hey Paul, we’re still looking into this on our end!

    We haven’t been able to replicate the same behavior, yet. Would you mind sending us a screenshot of the WP dashboard (with any sensitive info blocked, of course). You can send it to emailtesting[at]

    Make sure to include “WORDPRESS” in the subject line and we should be able to track it down! Also, if you could post here after the email is sent, we’ll know when we should be on the lookout!

    Thanks again, my man!

    thanks for the help, I sent the email.

    Plugin Author mc_nate


    Yo Paul!

    Sorry for all the back and forth. We did get your email, but would it be possible to send a screenshot of the plugins page with the MailChimp plugin that’s installed and activated. If possible, could you try to squeeze in the “settings” bar in the same page as well? We’ll try to replicate things on our end, but so far, we haven’t been able to repeat this same process.

    Send it to the same address if you don’t mind! emailtesting[at]

    Thanks dude!

    I sent a new screenshot

    Plugin Author mc_nate


    Hmm…. We still can’t replicate this same behavior on our end of things.

    What we might recommend is trying to upgrade to the latest MailChimp plugin (version 1.2.5) to see if that does add the option there. Failing that, it seems to be something local that’s preventing that option from popping up as expected from what we can tell. We have tried on a couple different versions of WordPress to no avail. Each time the plugin is added, the option does show up under “Settings”. In fact, in the new version, it’s showing up too much (which is another problem, entirely).

    Give us a shout back if there’s a piece of the puzzle that we’re missing. We’ll be happy to see if we can try to fill in the blanks from there. :\

    this is weird. when the plugin is activated and I click on Settings on ANOTHER plugin, it says “You do not have sufficient permissions to access this page.”
    and the URL looks like this:

    could it be that the serialized options are corrupt in the database?

    Plugin Author mc_nate


    Just to clarify, you’re saying the 1.2.5 version won’t allow you to edit any other plugins? Or the 1.2.4 version is still corrupting those other plugins?

    Paul, if you’re still having problems, I replied to a similar post about the cause and how to fix the issue. You could try the fix. Although I’m surprised that disabling all other plugins and reverting to the default theme didn’t work for you.

    Hey Paul/Nate,

    I am having the same issues here on WP 3.2.1…

    I firstly installed latest MailChimp plugin 1.2.5, and had the issue that Paul also has where ALL the plugins are incorrectly goven a ‘settings’ option when I install the MailChimp plugin (which leads to the ‘You do not have sufficient permissions to access this page’ error message).

    So I downgraded to 1.2.4 (I have used this version on sites where I have no issue), which eradicated the additional ‘settings’ anomaly, but I now don’t get a settings link to configure the plugin.

    This particular site has been problematical as the client tuns averything on a server where I only have SFTP access. I cannot upgrade any plugins through the WordPress interface – I have to do all via my FTP client – nor to I get a ‘Plugins > Editor’ option. I’m wondering whether this affects any permissions that the MailChip plugin requires…?

    I’m trying to see if there is a way around the FTP/SFTP issue – although I’m mindful of not compromising the client’s security (for his main website), so don’t want to leave any login details where they may be easily found.

    In the meantime, I have followed Jason’s link to fix the MailChimp 1.2.5 issues.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘mailchimp setting missing’ is closed to new replies.