• Resolved Susan Hayse

    (@suhayse)


    I’m having trouble getting my MailChimp audience segments to show up in the selector for segments/tags. Does it take time for those to show up or is it limited to just one segment?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Thread Starter Susan Hayse

    (@suhayse)

    Here’s what I’m seeing in the pulldown when I try to send a newsletter:

    https://snipboard.io/4BFgNU.jpg

    And here’s what I need to see:

    https://snipboard.io/hoLsdI.jpg

    Gotcha. Let me look into it on our end. Will get back to you!

    While I do that… Just to triple check…

    I noticed that the audience in the two screenshots were different… Have you tried updating to the correct audience to see if the correct segment shows up?

    • This reply was modified 1 year, 1 month ago by Member Hero.
    Thread Starter Susan Hayse

    (@suhayse)

    Yes, I caught that! Here’s what it looks like with proper audience. https://snipboard.io/ZIpwMx.jpg

    Thanks for your speedy attention! This plugin will be a dream come true for us!

    No problem. This will take a couple of hours to debug. Then we’ll test, and should be able to release an update by the time you wake up tomorrow. 🙂
    @suhayse

    • This reply was modified 1 year, 1 month ago by Member Hero.
    Thread Starter Susan Hayse

    (@suhayse)

    Thank you!

    All done! We’ve released an update to fix this. So just update the plugin on your end, and you should find that it works now.

    Here’s how it should look after you update the plugin:
    https://i.imgur.com/njE8yTI.gifv

    Please let me know if it’s all fixed on your side, @suhayse ! 🙂

    Thread Starter Susan Hayse

    (@suhayse)

    Maybe this is something wacky with my MailChimp setup, not the plugin.

    Here’s what I’m seeing in Mailchimp:

    Segments & Tags

    https://snipboard.io/IH0WDL.jpg

    https://snipboard.io/nLWaXt.jpg

    And here’s what I see in my Newsletter Glue settings in an individual post:

    https://snipboard.io/MQbRNl.jpg

    I tried creating a new API key, disconnecting the Mailchimp from the plugin, and removing unneeded tags and segments. Nothing seemed to work.

    It’s not mission-critical so I’ll just keep an eye on the settings to see if they start reflecting the actual segments. Thank you for your efforts – really appreciate it!

    Really strange. We’re still trying to figure out why this is happening on your end. As it’s working fine for us when we tested it.

    I’ll update here again once we figure it out.

    • This reply was modified 1 year, 1 month ago by Member Hero.
    Thread Starter Susan Hayse

    (@suhayse)

    No worries. I really appreciate your help. It may just be something strange with this particular audience group in MailChimp because our other audience groups seem to be coming through okay when I check them.

    That’s good to hear. 🙂

    Glad the rest are working.

    Member Hero

    (@memberhero)

    Hi @suhayse!

    Just wanted to let you know that we’ve finally found the bug that was preventing all audiences and segments from showing up.

    Please update the plugin, and let us know if it’s now fixed!

    Thank you!

    Thread Starter Susan Hayse

    (@suhayse)

    Woohoo! I figured out a workaround for that particular audience group, but thank you.
    I’ve really been enjoying the plugin.

    The only “flourish” I’d suggest is a double-ask when we send directly from the post (sort of like MailChimp’s old quivery, sweaty chimp finger when sending an email). “Are you sure you want to send this post as an email to your Mailchimp audience?”

    I’m suggesting this because I already goofed by not having “save as a draft in Mailchimp” selected when I updating an edit I made to the post – and sent the email a week too soon!

    Member Hero

    (@memberhero)

    Yikes! Seeing as you’re the second person to mention it, I’ll be working to figure out a solution for our next update.

    By the way, we’re now working on a paid version of the plugin which will include a whole bunch of custom blocks. Would you be interested in joining our closed beta? You can email me at hi at memberhero.pro and I’ll get you set up! 🙂

    Nearly forgot to mention… Our latest update also gives you the feature you requested to add the header image above or below the headline. You can access it in the settings. 😀

    Thread Starter Susan Hayse

    (@suhayse)

    That accidental send (like many accidents in life) had an upside, tho. We had a great open rate!

    Exciting to hear you’re working on a paid version! Well done!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘MailChimp segments’ is closed to new replies.