Support » Plugin: Mailchimp for WooCommerce » Mailchimp says: API Request Error – cURL error 28: Operation timed out

  • Resolved Rasti WebKinder

    (@rastiwebkinder)


    Hello

    We encountered a problem with version 2.1.12 of the plugin.
    When we insert API key, after a longer time loading we get an error message:
    Mailchimp says: API Request Error – cURL error 28: Operation timed out

    This doesn’t happen when we install version 2.1.9 (which we could confirmed worked on another shop of ours).

    Our setup:
    PHP 7.2.14
    WordPress 4.9.9
    WooCommerce 3.5.1

    Thank you for help in advance.

    Best regards
    Rasti

Viewing 15 replies - 31 through 45 (of 48 total)
  • I’m with Lightsail (AWS). Only version 2.1.11 works fine, now. I get the same error with all proceeding versions including the latest 2.1.15. I originally had 2.1.14 working fine when I first installed it, but it randomly started showing the API/bytes error one week ago.

    Tried everything the plugin author mentioned and went through dozens of threads regarding the issue, and see no errors that could cause the cURL issue per se. No files are being blocked, and there are no queue issues. I’ve boiled it down to the plugin itself causing the problem.

    Hopefully there is a fix, soon.

    I have the same problem
    PHP 7
    WOOCOMMERCE 3.5.7
    WORDPRESS 5.1.1
    MAILCHIMP 2.1.15
    cURL: 7.62.0, OpenSSL/1.0.2k

    Updated, didn’t work, downgraded to 2.11, still doesn’t work. Is this ever going to get fixed?

    What is the point of rolling out updates when they don’t actually resolve the issue?

    Hi there,

    I am starting from scratch and when i want to add the API Key that I copy paste from mailchimp, in wordpress i get the bellow message:

    Mailchimp returned the following error:
    Unauthorized. API Key Invalid. Your API key may be invalid, or you’ve attempted to access the wrong datacenter. Request: GET https://api.mailchimp.com/3.0/ Response: 401 Unauthorized – {“type”:”http://developer.mailchimp.com/documentation/mailchimp/guides/error-glossary/”,”title”:”API Key Invalid”,”status”:401,”detail”:”Your API key may be invalid, or you’ve attempted to access the wrong datacenter.”.

    What should I do to sort this asap.

    Thank you,

    Mailchimp says: API Request Error – cURL error 28: Operation timed out after 5001 milliseconds with 0 bytes received

    how do I solve this

    In the hope that some fix will come soon, here are other threads on the subject :

    https://wordpress.org/support/topic/api-request-error-curl-error-28/#post-11439726
    https://github.com/mailchimp/mc-woocommerce/issues/325

    Current Mailchimp plugin 2.1.15 is still buggy.

    2.1.11 works fine.

    • This reply was modified 1 year, 7 months ago by schawo.
    • This reply was modified 1 year, 7 months ago by schawo.
    • This reply was modified 1 year, 7 months ago by schawo.

    Mailchimp for Woocommerce 2.1.15 posts cURL error.
    Rollback to 2.1.11 works.

    I believe that any other stats are superfluous but if need be I can supply you with them.

    First-time install of the plugin on our site resulted in this error. Will try to use the old version as discussed in this thread, but I’m posting this to be notified of updates as well as for confirmation that it is still wide-spread and needs to be addressed.

    I have this issue too, Also replying for notifications of any fixes.

    MailChimp-Woocommerce: 2.1.15
    Woocommerce: 3.5.8
    WordPress: 5.1.1

    MtGamberWebsiteDesign

    (@mtgamberwesbitedesign)

    I received the same error this morning with

    Mailchimp for Woo 2.1.15
    Woo 3.6.2
    WP 5.1.1

    The plugin had previously been installed and then removed. Now realising that it was needed it had been re-installed a few weeks later.

    Using version Mailchimp for Woo 2.1.11 solved the issue for us.

    I am also getting this error at my site. it’s built in WordPress but not hosted by WordPress

    Rudi S.

    (@lashvegasadmin)

    I have been getting this error since version 2.1.12. I have tested this on different hosts and 2 different sites altogether and issue still persists. Below is error:

    “Mailchimp says: API Request Error – cURL error 28: Operation timed out after 5001 milliseconds with 0 bytes received”

    Kyle Hungate, you are wellcome to do some testing on my sites if you need.

    Regards,
    Rudi

    • This reply was modified 1 year, 6 months ago by Rudi S..
    Plugin Support khungate

    (@khungate)

    Hi there, our apologies for the radio silence. We just wanted to check back with you all to see if this was still a problem after our latest release (2.1.16). Please let us know when you get a moment, we’ll be happy to help troubleshoot further if necessary. The best place to get and track support is over at Github: https://github.com/mailchimp/mc-woocommerce/issues

    I get the same error, but only when trying to connect.
    The API-key itself works fine in the mailchimp plugin (not the mailchimp for woocommerce).

    After editing the wp-config.php with this line (found this online):
    define('MAILCHIMP_USE_CURL', true);

    I still get this error:
    Mailchimp says: API Request Error - ::

    Before editing the config file, the error was:
    Mailchimp says: API Request Error - The REST API seems to be disabled on this wordpress site. Please enable to sync data.

    I can’t find where to enable REST API (and i’m pretty sure it’s not disabled).

    ———-

    UPDATE:
    Downgraded to MailChimp for WooCommerce v2.1.11
    So far i’m able to insert all the data (key, sync etc) and it’s now syncing the webshop.

    UPDATE:
    Nevermind, the log file is full of “permission denied” because REST API is not enabled.

    2019-09-16T07:04:20+00:00 ERROR test.rest_api ::  :: Array
    (
        [status] => 403
        [body] => <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>403 Forbidden</title>
    </head><body>
    <h1>Forbidden</h1>
    <p>You don't have permission to access /wp-json/mailchimp-for-woocommerce/v1/ping
    on this server.<br />
    </p>
    </body></html>
    
    )
    
    2019-09-16T07:04:20+00:00 ERROR admin@validateCanUseHttpWorker :: The REST API seems to be disabled on this wordpress site. Please enable to sync data.
    2019-09-16T07:08:57+00:00 ERROR test.rest_api ::  :: Array
    (
        [status] => 403
        [body] => <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>403 Forbidden</title>
    </head><body>
    <h1>Forbidden</h1>
    <p>You don't have permission to access /wp-json/mailchimp-for-woocommerce/v1/ping
    on this server.<br />
    </p>
    </body></html>
    
    )
    
    2019-09-16T07:08:57+00:00 ERROR admin@validateCanUseHttpWorker :: The REST API seems to be disabled on this wordpress site. Please enable to sync data.
    2019-09-16T07:11:35+00:00 ERROR mailchimp_woocommerce_rest_api_get ::  :: 
    2019-09-16T07:11:35+00:00 ERROR admin@validateCanUseHttpWorker ::  :: 
    2019-09-16T07:13:00+00:00 ERROR mailchimp_woocommerce_rest_api_get ::  :: 
    2019-09-16T07:13:00+00:00 ERROR admin@validateCanUseHttpWorker ::  :: 
    2019-09-16T07:20:26+00:00 ERROR test.rest_api ::  :: Array
    (
        [status] => 403
        [body] => <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>403 Forbidden</title>
    </head><body>
    <h1>Forbidden</h1>
    <p>You don't have permission to access /wp-json/mailchimp-for-woocommerce/v1/ping
    on this server.<br />
    </p>
    </body></html>
    
    )
    
    2019-09-16T07:20:26+00:00 ERROR admin@validateCanUseHttpWorker :: The REST API seems to be disabled on this wordpress site. Please enable to sync data.
    2019-09-16T07:23:01+00:00 ERROR test.rest_api ::  :: Array
    (
        [status] => 403
        [body] => <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>403 Forbidden</title>
    </head><body>
    <h1>Forbidden</h1>
    <p>You don't have permission to access /wp-json/mailchimp-for-woocommerce/v1/ping
    on this server.<br />
    </p>
    </body></html>
    
    )
    
    2019-09-16T07:23:01+00:00 ERROR admin@validateCanUseHttpWorker :: The REST API seems to be disabled on this wordpress site. Please enable to sync data.
    2019-09-16T07:25:49+00:00 ERROR test.rest_api ::  :: Array
    (
        [status] => 403
        [body] => <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>403 Forbidden</title>
    </head><body>
    <h1>Forbidden</h1>
    <p>You don't have permission to access /wp-json/mailchimp-for-woocommerce/v1/ping
    on this server.<br />
    </p>
    </body></html>
    
    )
    
    2019-09-16T07:25:49+00:00 ERROR admin@validateCanUseHttpWorker :: The REST API seems to be disabled on this wordpress site. Please enable to sync data.
    2019-09-16T08:02:46+00:00 ERROR test.rest_api ::  :: Array
    (
        [status] => 403
        [body] => <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>403 Forbidden</title>
    </head><body>
    <h1>Forbidden</h1>
    <p>You don't have permission to access /wp-json/mailchimp-for-woocommerce/v1/ping
    on this server.<br />
    </p>
    </body></html>
    
    )
    
    2019-09-16T08:02:46+00:00 ERROR admin@validateCanUseHttpWorker :: The REST API seems to be disabled on this wordpress site. Please enable to sync data.
    2019-09-16T08:10:13+00:00 NOTICE plugin.activation.single_site :: Installing Mailchimp Tables For :: //www.vanrene.nl
    2019-09-16T08:10:13+00:00 NOTICE plugin.activation.single_site :: Installed Mailchimp Tables For :: //www.vanrene.nl
    2019-09-16T08:13:32+00:00 NOTICE sync.started :: Starting Sync :: Mon, Sep 16, 2019 8:13 AM
    • This reply was modified 1 year, 2 months ago by magicsun. Reason: Tried different solution, not that it fixes the current issue
    • This reply was modified 1 year, 2 months ago by magicsun.
Viewing 15 replies - 31 through 45 (of 48 total)
  • The topic ‘Mailchimp says: API Request Error – cURL error 28: Operation timed out’ is closed to new replies.