Support » Plugin: Mailchimp for WooCommerce » Mailchimp says: API Request Error – cURL error 28: Operation timed out

  • Hello

    We encountered a problem with version 2.1.12 of the plugin.
    When we insert API key, after a longer time loading we get an error message:
    Mailchimp says: API Request Error – cURL error 28: Operation timed out

    This doesn’t happen when we install version 2.1.9 (which we could confirmed worked on another shop of ours).

    Our setup:
    PHP 7.2.14
    WordPress 4.9.9
    WooCommerce 3.5.1

    Thank you for help in advance.

    Best regards
    Rasti

Viewing 15 replies - 1 through 15 (of 44 total)
  • Plugin Author ryanhungate

    (@ryanhungate)

    @rastiwebkinder thanks for reaching out.

    We’ve implemented this feature (which feels like a bug but it’s not) to try and address issues that some folks were running into making POST requests to the admin-ajax.php file. It’s an indicator that we can not communicate with that file through the function wp_remote_post which is what powers the queue system to sync your data to Mailchimp.

    Can we first start off by asking who your current web host is?
    Can you ask your web host whether or not they have blocked access to that file?
    Do you have any plugins that might be disabling that file?

    Thanks, we’ll be looking out for your response.

    Hi @ryanhungate

    Thank you for your feedback.
    To answer your questions:

    No we don’t have any plugins that would disable the file.

    Kind regards
    Rasti

    Plugin Author ryanhungate

    (@ryanhungate)

    @rastiwebkinder ok thanks – we have a couple more questions.

    1. Were you upgrading the plugin due to your data not syncing? Was it set up previously? I’m wondering now if we need to clear out your database table by deleting the plugin ( not just deactivating )… If you have access to your database table can you check to see if there are any records in the queue table? If so – we will need to flush that table. I could see how that might be playing a role in the server timeout during setup if there were jobs in there.

    2. Some hosts will disable POST requests to the admin ajax file. We need to see if that’s an issue.

    3. Another thing we’ve seen before is misconfigured servers that are on shared IP addresses. Or ‘still use’ the shared IP address with PHP CURL instead of a dedicated IP. Do you have a dedicated IP address currently, or are you on shared hosting?

    4. You MIGHT be getting blocked by the Akamai API gateway – if you have command line access to your server, you could make a quick attempt to see if your server itself is being blocked by calling the API directly. Please make use of this CURL command below.

    `
    curl -v -X GET https://{$DATA_CENTER}.api.mailchimp.com/3.0/ecommerce/stores?apikey={$API_KEY}
    `

    replace {$DATA_CENTER} with your actual data center at Mailchimp.
    ( you can see it in your API key ).

    replace {$API_KEY} with your actual api key from Mailchimp.

    Let’s start with these.

    I am facing the same error and just tested the plugin over two different DNS servers. Some other plugins to connect with Mailchimp API key are working alright. Hope to be helping to solve the problem.

    Thank you very much! 😉

    Plugin Author ryanhungate

    (@ryanhungate)

    @diegpl thanks for chiming in – but I’m a little confused on what you mean exactly?

    Can you please expand a little bit on what you’re doing, what you did to troubleshoot, and how we can assist?

    @ryanhungate
    1. This was a clean installation. So there were no records in queue table. (For reference: we just found out on another installation that previous versions worked.)

    2. We have other installations on the same server which are working with POST requests and handling them without problem.

    3. This particular installation is on a “angency server” which has a dedicated IP, but I am cross-checking that with the hoster — just to be sure.

    4. AKAMAI block was the first thing I checked (https://kb.mc4wp.com/solving-connectivity-issues/)

    Maybe it helps to mention that I checked if it was:
    memory_limit related (no)
    – curl version related (no)
    – DNS related (no)
    – mod_security related (no)

    Plugin Author ryanhungate

    (@ryanhungate)

    @rastiwebkinder ok thank you very much for the info. That the link you provided was not from our plugin – that’s another one… but it does address the same problem with Akamai – so thank you.

    Let’s try something else. Do you have WP-CLI enabled on your server? If so, I would like to see you do the following: open up your ssh terminal on the server and type:

    wp shell

    —- then in the shell —-

    mailchimp_call_http_worker_manually(true);

    Let it complete… this could be the problem – we have a 60 second timeout here, and your web server probably has a lower limit… I would like to see if the call completes – and how long roughly.

    If you don’t have access to the CLI, and would like to temporarily patch this code to get past the API key setting we can show you what to do – but this is the last step… so can we please try that first?

    I got the same error while trying to insert the API key, on two different domains being managed by two different DNS servers.

    Thank you.

    Plugin Author ryanhungate

    (@ryanhungate)

    @diegpl When you say two different DNS servers, I’m a bit confused on how that would matter – that’s just routing a domain to an IP address somewhere. Do you mean two different servers with different IP addresses that you control yourself?

    Have you tried any of the recommendations in this post yet? What are the results etc.

    Rudi S.

    (@lashvegasadmin)

    Hi,

    I also have this error now after I tried to resync my site with Mailchimp due to products that were not kept in sync with the previous Mailchimp API key. Now I am left with this error even after I tried deleting the plugin and reinstalling it.

    Is there a fix for this as yet?

    Thank you.

    Kind regards,
    Rudi

    I was able to fix this issue temporarily by downgrading to version 2.1.11 of the plugin here: https://github.com/mailchimp/mc-woocommerce/releases/tag/v2.1.11

    I’ve also logged an issue for the plugin: https://github.com/mailchimp/mc-woocommerce/issues/325

    Rudi S.

    (@lashvegasadmin)

    Thanks so so much Julien, your temp workaround fix it for me! Hope they can fix it in version 2.1.14 as the the version 2.1.13 which was released less than a day ago doesn’t have this bug fixed yet.

    I received the same error. I wasn’t getting the abandon cart to send so I followed the instructions here to delete the store and plugin on mailchimp and reload and resync. It won’t do it.
    I have confirmed with host that curl is on. I also tried the 2.1.13 version from above.

    Any help you can spare would be great

    • This reply was modified 7 months, 1 week ago by  jbib.

    Hi

    I have the same problem, but works fine with v201.11

    LB

    lukehutton

    (@lukehutton)

    We we’re seeing the cURL error 28 on attempting sync.

    After switching off this plug-in…

    Woocommerce Product Tab Pro

    It resolved/synced OK.

    luketom.com

Viewing 15 replies - 1 through 15 (of 44 total)
  • You must be logged in to reply to this topic.