Support » Plugin: Mailchimp for WooCommerce » Mailchimp says: API Request Error – cURL error 28: Operation timed out after 600

  • Mailchimp says: API Request Error – cURL error 28: Operation timed out after 60001 milliseconds with 0 bytes received

Viewing 5 replies - 1 through 5 (of 5 total)
  • I have worked with my host for hours and no luck. has to be something on Mailchimps side. it’s sad that this seems to be a known issue yet they do not fix it. If you find a solution please update us. Thanks!

    Version 2.1.11 works fine. I get the same error with all proceeding versions including the latest 2.1.15.

    It tries to make an API call to the WP api of the site on endpoint: /wp-json/mailchimp-for-woocommerce/v1/ping. Do you maybe have this disabled or is the endpoint unavailable on due to local enviroment?

    Plugin Author ryanhungate

    (@ryanhungate)

    @martijnn94 thanks for explaining that to @kingyyyy – we need to see whether or not @kingyyyy is using 2.1.16 version of the plugin for that new ‘rest api’ version.

    When a server is not responding to a request that’s made to its own domain name, that typically means there is a configuration on the server that’s out of whack. Some CURL installations are set up in a way that might require you to set a specific IP address or even use localhost etc., so we’ve got some options for you if you’re in that situation as well.

    First config option is to set define('MAILCHIMP_USE_CURL', true); in your wp-config.php file. This will make an attempt at using raw CURL vs. wp_remote_x calls. We’ve found that some plugins are indeed altering the core functionality of this function we rely on.

    Second option is to make a change to the REST IP address that we will be calling. You may do that by specifying define('MAILCHIMP_REST_IP', 'your.ip.here');. You may also use localhost by specifying define('MAILCHIMP_REST_LOCALHOST', true); and we will use the localhost address to make http calls to your own server instead of your actual domain name.

    Third option is that you might need to specify a particular TLS version. By default we’re using the CURL_HTTP_VERSION_1_1 but if for whatever reason you need to change that to something your server admins tell you to do, you may do so by adding in a config of define('MAILCHIMP_USE_LOCAL_CURL_VERSION', 'whatever');

    We’re working really hard on finding solutions for all the possible server configurations, but in all fairness it’s a little hard to communicate these things without overwhelming most folks. If you don’t mind working with us to find your solution, we will get you where you need to be.

    Please feel free to reach out to us again with questions, and if you are able to fix this using our tweaks listed above.

    Plugin Author ryanhungate

    (@ryanhungate)

    @barrosofilho we’ve released version 2.3 of the plugin yesterday which should resolve your syncing issue you’ve described. Please update or re-install and let us know if this solved your issue. Looking forward to your response.

    Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this review.