Support » Plugin: Mailchimp for WooCommerce » Mailchimp says: API Request Error – 0 :: on 1665

  • Resolved JoAnn22

    (@joann22)


    I am trying to use this plugin to connect my clients WooCommerce with MailChimp. I keep getting this error every time I try:

    Mailchimp says: API Request Error – 0 :: on 1665 in /var/www/wp-content/plugins/mailchimp-for-woocommerce/includes/api/class-mailchimp-api.php

    I have uninstalled reinstalled the plugin multiple times. It connects to MailChimp because I see it in the Authorized Applications section on the API page.

    When I look at the logs in WooCommerce this is the error popping up:

    2019-11-07T04:03:35+00:00 ERROR admin@validatePostApiKey :: 0 :: on 1665 in /var/www/wp-content/plugins/mailchimp-for-woocommerce/includes/api/class-mailchimp-api.php

    Any help on how to get past this? I can’t do anything on the plugin page, but it just gives me that first error. I have done everything I’ve read to do, and it still won’t connect.

Viewing 6 replies - 1 through 6 (of 6 total)
  • I’ve got the exact same error here. A solution to this problem would be greatly appreciated.

    Plugin Author ryanhungate

    (@ryanhungate)

    @joann22 and @kshh this seems like you might be using a shared IP address. Can you please verify that you’re on a host that does this for your domain?

    Also – have you reached out to Mailchimp directly to ask them if they can check to see if your IP address is currently on the Akamai blacklist?

    The reason your app shows up in the “authorized apps” area is because you did authenticate with the login popup, and that did register the connection, but when the api key was passed back to your server, you were not able to communicate with the API – which is why I brought up the blacklist problem. It’s a known issue, but the solution is not on Mailchimp, it’s on the web server itself and hosting providers to fix this issue.

    If you are on that blacklist, you’ll need to move your domain to a “dedicated IP”. You may end up needing to alter your DNS records as well – but it will be better for your domain while it makes calls to external services like this.

    Lets start with the first part where you ask your host about the Shared IP vs. Dedicated IP and we’ll look out for your response here.

    Thanks for writing in!

    Same error, no solution?

    Mailchimp says: API Request Error – 0 :: on 1665 in /home/p70tp5wpy8se/public_html/wp-content/plugins/mailchimp-for-woocommerce/includes/api/class-mailchimp-api.php

    Same sort of error – domain not listed on Akamai…

    “Mailchimp says: API Request Error – on 1665 in /var/www/wp-content/plugins/mailchimp-for-woocommerce/includes/api/class-mailchimp-api.php”

    Plugin Author ryanhungate

    (@ryanhungate)

    @bphyle @sundaydriverxxx

    This is a Mailchimp API data center connectivity issue that will be resolved in version 2.3.1. Please stay tuned for this release. You are free to try the re-sync method which has been known to work. All you need to do is apply a query string of &resync=1 to the overview tab – and click enter… after that you will see a button that says RESYNC which might indeed solve your problems.

    Please feel free to reach back out or create a new ticket if you’re still experiencing this issue.

    Plugin Support khungate

    (@khungate)

    @bphyle @sundaydriverxxx thank you for your patience. This issue has been patched in the latest release that came out yesterday (v2.3.1). Please let us know if you still are experiencing any problems.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.