Support » Plugin: Jetpack by WordPress.com » MailChimp Pop up not working

  • Resolved gadgetsforbusiness

    (@gadgetsforbusiness)


    Hi! I have relentlessly tried to find a solution to the reason as to why the pop up is not showing. I have put the code into my header and tried the jetpack plugin. When I first uploaded the pop up via the Jetpack mailchimp pop up widget, it worked. Now, I can’t get it to show up anywhere after I have cleared my browser and cookies. Please help me out and let me know if there is a resolution to this issue. Also it would be a great help if someone could bring up my website on their browser to see if it comes up. Thank you so much.

    Sincerely,
    Chaz H.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support darnelldibbles

    (@darnelldibbles)

    Hi @gadgetsforbusiness,

    I went to your site and was able to see the pop up without issue (in Chrome):

    Screen Shot

    Second time I visit, I am only seeing a collapsed version of the pop up at the bottom right:

    Screen Shot

    is that how you have it set up? It did the exact same thing when I visited via Safari.

    Usually, pop ups only show up once and stores a cookie for the remaining visits, as you referenced clearing your cookies. Did you try a different browser to see if it popped up? Everything looks good on this end.

    Hope that helps!

    That pop up is my live chat. There should be a large pop up that comes up in the middle of the screen. Also, yes i have tried clearing my browsers and using other peoples computers and nothing comes up.

    Let me know if you have any other suggestions.

    thank you,
    Chaz H.

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    You’re right, all I see is the livechat popup.

    Is it definitely configured as detailed at https://jetpack.com/support/extra-sidebar-widgets/mailchimp-subscriber-popup-widget/ ?

    Sometimes I find it good to just wipe out what you did before and try again.

    If it’s still no good, are you using any sort of caching plugin, or do you see a “Clear/Purge Cache” button in your Dashboard or admin bar? If so, would you please try clearing the cache?

    Note: You do not need to install a caching plugin at this point just to clear a cache you don’t have. If you don’t have a caching plugin or a way to clear a server-level cache, just say so. 🙂

    I do have a caching plugin and have also tried to clear the cache. Could the problem be a plugin that I have installed.

    Plugin Support Gemma Evans

    (@gemmaevans)

    Hi @gadgetsforbusiness,

    Could the problem be a plugin that I have installed.

    I can see you have the WP Fastest Cache plugin installed. It would be worth deactivating this plugin to see whether it has any effect — let’s try doing that and see how things look afterwards.

    I wasn’t sure from your reply whether you have already tried deactivating that plugin, so just let us know 🙂

    Okay thank you i’m going to test that out.

    I just deactivated the plugin – reinstalled the mailchimp pop up widget – posted the new code into the box – then cleared my cache. I went into a new incognito window but nothing came up. Any other plugins to delete or other suggestions?

    Thank you,
    Chaz H.

    Plugin Support darnelldibbles

    (@darnelldibbles)

    Any other plugins to delete or other suggestions?

    Ah, I see you have the Plugin MailChimp For WordPress enabled. Because the Mailchimp plugin MailChimp For WordPress is enabled on your website the Jetpack Widget will not work. Jetpack disables its inbuilt features in favor of plugins installed on the user’s website.

    Can you please try disabling the MailChimp-for-wp widget and check if the Jetpack Widget works properly? Let me know if that works for you.

    Thanks,

    So I deleted the jetpack widget cleared my cache and added the code to a text box widget and nothing came up. I also tried putting it in my <head>. Then I opened up a custom HTML widget and installed the code there and it works!!!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.