Support » Plugin: MailChimp List Subscribe Form » mailchimp plugin v1.2.5 settings corruption

  • i updated [auto update via wp backend] to mc plugin v1.2.5 [wp v3.2.1] but update added settings options to all plugins [when ANY plugin setting options clicked would return a ‘You do not have sufficient permissions to access this page’ error]. i then deleted and reinstalled mc plugin v1.2.4 and no longer have mc settings listed under wordpress settings menu. any help would be most appreciated.

    http://wordpress.org/extend/plugins/mailchimp/

Viewing 15 replies - 1 through 15 (of 39 total)
  • Plugin Author mc_nate

    (@mc_nate)

    Hey there. Ms Deadlines!

    We have tried to replicate this same behavior by upgrading and downgrading, but haven’t been able to repeat the same results. Are there any other plugins that are installed, currently? If so, have you tried to de-activate those other plugins and re-activate the MailChimp one?

    Give us a shout back if we can further assist. We’ll be happy to dig in a little further!

    Cheers.

    yes other plugins installed. how can i completely uninstall mc plugin so that i can do a clean reinstall to troubleshoot? i have seen that similar issues have been reported by other users of the v1.2.5 mc plugin http://wordpress.org/support/topic/plugin-mailchimp-list-subscribe-form-125-adds-settings-link-to-all-plugins?replies=4

    Plugin Author mc_nate

    (@mc_nate)

    Hey again!

    Yeah, we are aware of that extra “settings” issue. The best way to get rid of the MailChimp plugin would be to completely delete that file from your plugins directory through FTP. Then you could re-install a different version of the plugin the normal way, again.

    Let us know if that has any more success!

    yes i have deleted and reinstalled via sftp however is not recognized as fresh installation allowing me to reapply mc account api …

    Same issue here.

    The Mailchimp plugin overrides the settings of most of my plugins. I cannot access the settings of important plugins anymore.

    I’ve tried an FTP uninstall right now… but it didn’t work.

    Plugin Author mc_nate

    (@mc_nate)

    Hrm…

    When the plugin is disabled, we’re seeing that extra “settings” option disappear, which is the expected behavior. However, any plugin with a native “settings” link should still work. Would you guys mind sending us a screenshot of the plugins page in your account? You can send the screenshot to emailtesting [at] mailchimp.com.

    We’ll be happy to take a look that way!

    Cheers

    I have the same issue, it’s adding an extra Settings link to some of my plugins

    sorry, am unable to send screenshots as i reverted back to plugin v1.2.4 when i was unable to resolve the settings issues with v1.2.5 …

    @mc_nate

    The bug is on line 71 in mailchimp.php

    The existing code is:

    add_filter('plugin_action_links', 'mailchimpSD_plugin_action_links', 10, 1);

    This should be changed to something like the following (works for me):

    add_filter('plugin_action_links_' . plugin_basename( __FILE__ ), 'mailchimpSD_plugin_action_links', 10, 1);

    tnx Jason – that works

    tried jason_lane suggestion. although settings issue for other plugins resolved. mc plugin v1.2.5 settings now returns error: You do not have sufficient permissions to access this page.

    and when using sign-up form [not widget, code inserted into sidebar] although sign-up request goes through form submit returns error: Invalid argument supplied for foreach() in /home/account/wp-content/plugins/mailchimp/mailchimp.php on line 1189

    as these issues seem to have been have been reported numerous times i have again reverted back to plug-in v1.2.4 until resolved :]

    @msdeadlines – It turns out I had the same permissions problem, but I hadn’t noticed (didn’t actually trying clicking on the Mailchimp Settings). Anyway, I found the fix to that one, too. The Mailchimp plugin is checking for user capability ‘edit_plugins’, which seems logical, but it turns out that the ‘edit_plugins’ cap can be switched off globally by the command:

    define( 'DISALLOW_FILE_EDIT', true );

    In my case, I am using the “Better WP Security Plugin” and have ticked the option to “Turn off file editor in WordPress Back-end.” which means admins no longer have the ‘edit_plugins’ capability, and therefore the Mailchimp settings page doesn’t let them in. You may have a similar security plugin installed, or even a theme that is disabling the file editor. The quick fix is to change the defined cap on line 31 of mailchimp.php:

    define('MCSF_CAP_THRESHOLD', 'edit_plugins');

    I usually use ‘manage_options’ on my plugins. Once you’re able to get to the settings page, you may just need to check that everything is configured correctly, and hopefully your form submission problem will get fixed. Based on the error you posted, it sounds like something to do with your Interest Groups settings.

    For extra information about the ‘edit_plugins’ cap issue:

    http://wordpress.org/support/topic/edit_plugins-capability?replies=2

    The WordPress edit_plugins capability

    jason_lane … indeed :]

    yes much thanks!

    replaced define(‘MCSF_CAP_THRESHOLD’, ‘edit_plugins’); with define(‘MCSF_CAP_THRESHOLD’, ‘manage_options’);

    & added hidden group [necessary to Update List in mc plugin settings]

    both issue resolved …

    Brilliant Jason – fixed both the ‘Settings’ issue, and the missing ‘MailChimp Setup’ link. Thanks!

    Just changed

    define(‘MCSF_CAP_THRESHOLD’, ‘edit_plugins’);

    but I still cannot access the settings for other plugins. The Settings links of other plugins still send me to the Mailchimp settings page.

    Maybe I should add hidden group, as msdeadlines suggested (I have no idea how to do this 🙁 ?

    At this point, I would be fine just deleting the Mailchimp plugin in order to access much important ones, but it doesn’t seem to be possible.

    I’m really at loss here…

Viewing 15 replies - 1 through 15 (of 39 total)
  • The topic ‘mailchimp plugin v1.2.5 settings corruption’ is closed to new replies.