WordPress.org

Support

Support » Plugins and Hacks » Mailchimp plugin not enqueuing scripts

Mailchimp plugin not enqueuing scripts

  • It seems like Mailchimp v 1.2.5 is not enqueuing scripts when it says it should. If I check ‘Use javascript support’ the js should load from wp_head(), right?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hmm. Can you provide a website URL so we can check this out?

    Is the JavaScript working at all when you select the option in the settings?

    Eep eep!

    http://www.joshuasofaer.com/

    As you can see the form is in the footer. The ie.css stuff is sitting in the head fine, but no javascript. I have wp_head() and wp_footer() in place as normal.

    A

    Hey again!

    We haven’t been able to replicate this same behavior on our end of things, so we wanted to check a few different options. Are there any other plugins that are enabled on this same page that might be moving javascript to the footer? Or are there any caching plugins that might need to be updated or reloaded?

    Give us a shout back and we’ll be happy to have a peek!

    Cheers

    Hi

    Even if javascript were moved to the footer, you’d expect to see it in the source – which you can’t. I do use a caching plugin, but then it’s not working on my local site either, and there’s no caching happening there. I’ll switch themes and try that out.

    Thanks.

    Right on.

    We were just wanting to make sure that we weren’t conflicting with any other plugins that might cause the script not to load. If you do continue to see issues, give us a shout and we’ll see what else we can sort out.

    Cheers

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Mailchimp plugin not enqueuing scripts’ is closed to new replies.
Skip to toolbar