WordPress.org

Forums

MailChimp List Subscribe Form
Mailchimp only working on homepage, but format is wrong on all others (2 posts)

  1. jlove83
    Member
    Posted 2 years ago #

    Hello,

    Having a problem with the Mailchimp plugin on every page except the homepage. I'm not sure if it is the template that is creating the problem or what.

    This is what it looks like on the homepage, which is correct:

    http://www.karenharold.com

    But on every other page the submit button isn't showing up.

    http://www.karenharold.com/media/

    Please help!

    http://wordpress.org/extend/plugins/mailchimp/

  2. mc_nate
    Member
    Posted 2 years ago #

    Hey there!

    Thanks for the comparison shots there. In looking at the code for the site, it appears there's some CSS that's overriding the styling for the button on the other pages. Specifically, the background color is getting changed to "white", which makes the button look... strange. After I manually changed the styling in the CSS, things looked okay.

    Basically, what you'll want to do is add some styling for the MailChimp button classes:

    #mc_signup_submit.button {
    background-color: _____________;
    }

    When I was testing in Chrome, I set it to blue and got the following results:

    http://cl.ly/image/2N3H140z0v1v

    Hopefully that helps a bit with getting things straightened out!

    Cheers

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic