Support » Plugin: Atomic Blocks - Gutenberg Blocks Collection » Mailchimp List not loading in Email block

  • Hi,

    I am working on a website that has Genesis Authority Pro theme and that theme require Atomic Block plugin to set up the demo.

    For some reasons the email block in it is not loading the list names. I tried reentering API key and also disabling all other plugins but still it didn’t work.

    Please help.

    Thanks,
    Jay

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author John Parris

    (@mindctrl)

    Hi Jay,

    When you add a key and AB fetches the lists on the account, those results are cached for 15 mins so that your site doesn’t hit the Mailchimp servers too frequently. If you entered a key that was perhaps incorrect or for an account that didn’t have a list, it would take 15 mins for that data to be refreshed. We have it on our todo list to automatically refresh them when the key is changed, to avoid confusion like this.

    Have you tried after a 15 minute wait to see if the lists show up now?

    Yes, I did.

    When I enter API key in AB how do I know if it’s fetching lists? When I enter the API key and hit the save button I just get “Settings saved” message.

    Plugin Author John Parris

    (@mindctrl)

    The lists are fetched automatically and should show up in the dropdown menu in the sidebar when you add the block to a page.

    If you’re not seeing the lists there, you can manually clear the cache using the Transients Manager plugin. When you install and activate that plugin, you can go to Tools > Transients and click the Delete All Transients button. See if that fixes it up. If you still don’t see the lists, go back to Tools > Transients, find the one called atomic_blocks_mailchimp_lists, click the Edit link, and see what the Value says.

    I did that and still not seeing lists.

    “atomic_blocks_mailchimp_lists” is not in Transients list.

    Plugin Author John Parris

    (@mindctrl)

    Hmm. It sounds like your site may be having issues communicating with the Mailchimp API. Does your web host have php-curl installed on your site?

    Not sure, how can I check?

    Plugin Author John Parris

    (@mindctrl)

    It may show in the Site Health report under Tools, but the easiest way is probably reaching out to the support folks at your host.

    Okay

    I spoke to my hosting provider and they said PHP-CURL is installed on my website.

    Plugin Author John Parris

    (@mindctrl)

    Thanks for checking. Can you show me screenshots of how the block looks inserted into the page, along with its settings in the editor sidebar?

    Plugin Author John Parris

    (@mindctrl)

    @jay_chauhan did you figure this out?

    Hi, not exactly.

    I contacted my host to find a solution for this and they are not able to find a solution for this, they are telling me to contact Mailchimp.

    There is nothing wrong with your plugin too. I moved my website to cPanel hosting from Managed WordPress and it’s working fine there.

    I am guessing there is some issue with your plugin with Managed WordPress host.

    Plugin Author John Parris

    (@mindctrl)

    Thanks for the update. Glad to hear you got it working on another host. I’ve used it this block on a few different hosts, one which is the WP Engine managed host platform. It works on all the ones I’ve tested on, which isn’t a lot but it’s been on 4 different ones so far. The only time I’ve seen any issues at all is when the host is missing php-curl, or has the inappropriate version installed for the version of PHP that’s active. I’m curious which host you’re having an issue with? Maybe we can dig into it.

    It’s Godaddy Managed WordPress hosting.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.