Support » Plugin: Mailchimp for WooCommerce » Mailchimp for Woocommerce is not yet connected to a Mailchimp account.

  • Hi, just done an update to this plugin and now its saying:
    “Mailchimp for Woocommerce is not yet connected to a Mailchimp account.”
    I don’t remember setting up a mailchimp account before…
    So, can I just leave this? or is it now forcing me to have an account?
    Thanks…

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Support khungate

    (@khungate)

    Hi @sonic1243, without seeing the plugin in your store, it sounds like you may just need to do a fresh uninstall & reinstall. Can you give that a try with the latest plugin version and report back?

    Plugin Support khungate

    (@khungate)

    Hi @sonic1243, we just wanted to check back with you to see if this was still a problem with our latest plugin (2.4.5 at the time of this post). Please let us know when you get a moment, we’ll be happy to help troubleshoot further if necessary.

    Thread Starter sonic1243

    (@sonic1243)

    Hi, sorry for no reply! I’m still getting the warning message in Admin; but this obviously can’t be causing any issues as we’re taking orders and the emails seam to be going out as normal etc. Running Version 2.4.5.
    Thank you!

    Plugin Author ryanhungate

    (@ryanhungate)

    @sonic1243 just to be clear on the issue – were you saying that the warning was coming from within your Mailchimp account, or the WooCommerce plugin specifically?

    We would like to get to the bottom of that for you but would first like to know which area we’re talking about in order to guide you in the proper direction next.

    Thread Starter sonic1243

    (@sonic1243)

    It’s at the top in WP Admin, on all pages, notification saying:
    “Mailchimp for Woocommerce is not yet connected to a Mailchimp account. To complete the connection, visit the plugin settings page.”
    Appeared after updating the plugin…

    Plugin Author ryanhungate

    (@ryanhungate)

    @sonic1243 do you happen to use any caching plugins at all? This notice should only be showing up if you’ve got the plugin installed – but only when you haven’t set it up entirely.

    Can you verify that you’ve got the plugin configured, and is syncing up orders / customers as of recent? You can see log entries for the most recent activity in your store?

    Might need to just do a quick “purge the cache” operation possibly if you’re using a cache – maybe that might be in the way of this working too. Really tough to say.

    Plugin Support khungate

    (@khungate)

    Hi @sonic1243, we just wanted to check back with you to see if this was still a problem with our latest plugin (2.4.7 at the time of this post). Please let us know when you get a moment, we’ll be happy to help troubleshoot further if necessary.

    Thread Starter sonic1243

    (@sonic1243)

    Just updated the plugin now and the “not connected” notification has gone away!
    Thank you….

    Plugin Author ryanhungate

    (@ryanhungate)

    oh good news @sonic1243 thanks for reporting 🙂

    Thread Starter sonic1243

    (@sonic1243)

    Just updated to 2.5.0 and that message is back! As before.
    (Also, on first attempt to update the plugin it failed; timed out on the download. Second attempt worked fine.)

    nanferns

    (@nanferns)

    hello, I am getting the same error now

    Thread Starter sonic1243

    (@sonic1243)

    This problems is still there at the moment … thanks!

    Plugin Author ryanhungate

    (@ryanhungate)

    @sonic1243

    This function is checking to see if there is a Mailchimp API key and a Mailchimp List ID that have been saved. If it’s not saved, that means the plugin still needs to be configured. This is the purpose of that notice.

    That is very odd if you’ve configured the plugin already – and my first guess at this would be that you might be using some sort of caching engine?

    Can you please do a cache clearing if you are so that we’re using a fresh value? Sometimes the “site options” get cached and we’ve seen this behavior. Also – if you’re using anything that might be cleaning up old site option records?

    Plugin Support khungate

    (@khungate)

    Hi @sonic1243, we just wanted to check back with you to see if this was still a problem with our latest plugin (2.5.1 at the time of this post). Please let us know when you get a moment, we’ll be happy to help troubleshoot further if necessary.

    Thread Starter sonic1243

    (@sonic1243)

    Hi cool thanks .. yes the message has been there for a long time now, and is still there after doing the latest update…

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.