Support » Plugin: Ocean Extra » Mailchimp widget Failed to subscribe, please contact admin.

  • glotfy

    (@glotfy)


    Hi,
    mailchimp was working well, I recreate my website and put API key in theme panel and recreate the Audience (list) on mailchimp but every time I try to subscribe I receive the following error ” Failed to subscribe, please contact admin.”
    shall I used any other plugin.
    Note: I already use WP SMTP Mail

    • This topic was modified 6 months ago by glotfy.
Viewing 14 replies - 1 through 14 (of 14 total)
  • Amit Singh

    (@apprimit)

    Hello,

    Have you selected double optin or single optin in the MailChimp account? Try to select it Single Optin and check it works or not.

    glotfy

    (@glotfy)

    Hello Amit,

    I did not select double optin in the MailChimp account.

    Amit Singh

    (@apprimit)

    Can you link to your site, please? Also, try to update the PHP version if it is not PHP7.

    glotfy

    (@glotfy)

    site link

    https://epiphaniusmacar.com

    I update the PHP version to 7, same issue

    Amit Singh

    (@apprimit)

    Can you link to the page where you have MailChimp widget? I didn’t see it on the home page.

    glotfy

    (@glotfy)

    Amit Singh

    (@apprimit)

    That’s odd. Sorry but I don’t know the exact reason why it is not working on your site and our support is very limited here. Try to disable/enable plugins to check for a possible conflict.

    glotfy

    (@glotfy)

    Ok, Thank you I will try to use the following plugin Mailchimp for WordPress and see if it fixes the issue or not
    Thank you.

    glotfy

    (@glotfy)

    I tried the plugin but it didn’t work, I deleted the campaign and the audience list but no use, I deactivate antivirus and jetpack plugin but no use.
    I paste the code as a custom HTML code in the posts page and it’s now working.
    Thank you.

    • This reply was modified 6 months ago by glotfy.
    Amit Singh

    (@apprimit)

    Glad to hear that you found a solution!

    So I just implemented Mailchimp, and I was having this issue in my footer form. The reason it wasn’t working is that in the wordpress theme panel settings, where you put the API and List ID, the List ID needs to be the code, not the alphanumeric name of the list. You can find this under Audience Name and Campaign Defaults from your Mailchimp dashboard.

    Thank you for your reply, I already added them in theme panel integration and it was working but it suddenly stopped, any way I used another plugin instead of MailChimp and it’s now working.
    Thank you.

    Hi @glotfy

    I think i found a solution. I was facing the same problem. The monkey named mailchimp is wild and it is taking time for #metoo to tame it:

    In your mailchimp, go to audience – click view contacts – settings – audience fields and merge tags-uncheck all fields under Required?

    Hope this should help.

    Hello

    I’m having this same issue in the mailchimp footer widget

    https://dantecapelli.com.br

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.