Support » Plugins » mailchimp broken under 2.9

Viewing 10 replies - 1 through 10 (of 10 total)
  • I would also love to see an update posted. I use Mailchimp for my business all the time.

    I just tested the plugin on a clean WP29 install and it works fine. That generally has meant that it’s actually running into a conflict with another plugin you have installed that’s doing something weird. If you can figure out which one, there’s a small chance we may be able to work around whatever the other plugin is doing. However it may also be something the other plugin’s author will need to correct.

    OK, thanks for the response..

    it’s probably due to some problems during the WP upgrade, but still MailChimp plugin is the only one giving me notices, they look like that:

    Notice: Undefined index: mc_list_id in /usr/local/pem/vhosts/117068/webspace/httpdocs/ on line 175 Notice: Undefined index: mc_list_id in /usr/local/pem/vhosts/117068/webspace/httpdocs/ on line 216

    any idea what’s up? thanks in advance!

    yep, and after signing up from the front end I get this notice:
    Notice: ob_end_clean(): failed to delete buffer. No buffer to delete. in /usr/local/pem/vhosts/117068/webspace/httpdocs/ on line 5 Notice: ob_end_clean(): failed to delete buffer. No buffer to delete. in /usr/local/pem/vhosts/117068/webspace/httpdocs/ on line 5 Notice: Undefined index: mc_mv_MMERGE3 in /usr/local/pem/vhosts/117068/webspace/httpdocs/ on line 41

    I still get signed up and get the confirmation email…

    Hello there,

    As I tested mailchimp extension and widget, I noticed that a multichoice field isn’t retrieved from the mailchimp list.

    I get this :
    <input type="text" size="18" value="" name="mc_mv_SERVMESSAG" id="mc_mv_SERVMESSAG" class="mc_input"/>

    I use latest 2.9.1 wordpress version.

    I’m unable to get it working as well. The plugin is installed and activated. It was able to go to the MailChimp Setup screen and everything seemed to work there. But when I go to the widgets screen, I don’t see anything that has to do with Mailchimp.

    I followed the instructions for the advanced setup and modified one of my pages to call the function directly, but then half the page doesn’t show up.

    This is the only active plug-in and I’ve also tried it using the Exec-PHP plug-in with no change. Anyone have any thoughts? I was hoping to get this running quickly. Do I need to use an older version of the plug-in? I’m using version 1.1.8 and WordPress 2.9.1, which I had upgraded from 2.8.x. Don’t recall specifically which minor version it was, but it didn’t work there, so I upgraded WordPress to try and fix it.

    The upgrade was fine, but the MailChimp widget still doesn’t show up for me. Anyone have any ideas?

    I found the problem on my installation. Line 31 of mailchimp.php has the following line:


    The error logs complain about an invalid path to the file and I think it’s because it doesn’t allow a default path of the local directory. That’s probably a setting on my server.

    If you are experiencing the same issue, change this line as follows, it works fine.

    include_once(str_replace('//','/',dirname(__FILE__).'/') .'mailchimp_includes.php');

    Hello again,
    Here is some code I wrote to display a radio type choice field from a mailchimp list.

    	echo '<div class="mc_merge_var">';
    	echo '<label for="'.$opt.'" class="mc_var_label">'.$var['name'];
    	if ($var['req'] && $num_fields>1){ echo ' *'; } // Not sure about this feature in mailchimp
    	echo '</label>';
    	foreach($var['choices'] as $choice){
    		echo '<input type="radio" name="'.$opt.'" value="'.$choice.'" /> '.$choice."<br />\n";
    	echo '</div>';

    placed inside if ($var['req'] || get_option($opt)=='on'){

    in mailchimp_includes.php

    Are you interested in fixing that feature ?

    It works actually … there might be some other code to add …

    Sorry for the delayed response to some of you… some answers:

    @chodorowicz for some reason your server has PHP notices turned on, which is a funky thing for a live site. I may look at doing something to suppress them at least in our plugin, but I would imagine you are going to keep running into things like that until they are turned off.

    @mstaber hadn’t seen that before. I’ll look at adding something similar so others don’t run into issues.

    @djosfr yes, I’m aware we don’t have support built-in for all of the fancy data types offered. Pretty much anything that’s can’t be adequately represented by a text field still needs to be added. That includes at least both multiple choice options (drop down + radio), address fields, and date fields. It’s possible we may take the time to get them all working in the future.

    @mc_jesse I’ve checked the error_reporting setting in php_info() and it’s 6143 – so that means that all errors and notices are echoed? still, it’s strange that these notices started to pop up after an upgrade to WP 2.9 which was done by client himself so maybe some errors happened during the intallation

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘mailchimp broken under 2.9’ is closed to new replies.