Support » Plugin: Mailchimp for WooCommerce » Mailchimp API Request Error – 503 :: on 1665

  • Resolved scody

    (@scody)


    We are getting this below error when we try to connect to MailChimp account

    Mailchimp says: API Request Error – 503 :: on 1665 in /home/xxxxxxx/public_html/wp-content/plugins/mailchimp-for-woocommerce/includes/api/class-mailchimp-api.php

    Please advise how to resolve this issue.

    Thanks in advance.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support khungate

    (@khungate)

    Hi @scody, thanks for reaching out. Since you’re currently receiving a 503 error code, that’s coming from Mailchimp’s API gateway service (Akamai). The quick and easy way to see if the problem was temporary is to perform a fresh uninstall and install. If the problem persists, troubleshooting something like this is can be technical in nature and we suggest asking your host or a 3rd party developer for help if you’re not comfortable running the following commands:

    The first step is to see if your server can communicate directly with the Mailchimp API using the CURL command below: curl -v -X GET https://{$DATA_CENTER}.api.mailchimp.com/3.0/ecommerce/stores?apikey={$API_KEY}

    Please replace the $DATA_CENTER and the $API_KEY with your credentials. You can locate the $DATA_CENTER number in the URL, for example, us19. If you receive a valid response from the Mailchimp API, that helps us solve the first step of determining whether or not your server has been IP Blacklisted by the API gateway.

    Once we’ve verified that you are able to make calls directly using CURL – we can then see if there might be another SSL handshake issue / OpenSSL / libCURL issue that might need to be addressed by your server admins.

    Give that a try and let us know if it solved the issue. I look forward to hearing back from you.

    scody

    (@scody)

    Thanks @khungate, for a quick reply. We are getting this below response for the cURL command,

    * About to connect() to xxxx.api.mailchimp.com port xxx (#0)
    *   Trying xxx.xxx.xxx.xxx...
    * Connected to xxxx.api.mailchimp.com (xxx.xxx.xxx.xxx) port xxx (#0)
    * Initializing NSS with certpath: sql:/etc/pki/nssdb
    *   CAfile: /etc/pki/tls/certs/ca-bundle.crt
      CApath: none
    * SSL connection using TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384
    * Server certificate:
    *       subject: CN=wildcardsan2.mailchimp.com,OU=IT,O="The Rocket Science Group, LLC",L=Atlanta,ST=Georgia,C=US
    *       start date: Jul 09 00:00:00 2019 GMT
    *       expire date: Oct 07 12:00:00 2020 GMT
    *       common name: wildcardsan2.mailchimp.com
    *       issuer: CN=DigiCert SHA2 Secure Server CA,O=DigiCert Inc,C=US
    > GET /3.0/ecommerce/stores?apikey=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx HTTP/1.1
    > User-Agent: curl/7.29.0
    > Host: xxxx.api.mailchimp.com
    > Accept: */*
    >
    < HTTP/1.1 503 Service Unavailable
    < Server: Apache
    < Content-Length: 125
    < Content-Type: application/json
    < ETag: "953d389c654d003dd7a67b8f959df97a:1452000673"
    < Cache-Control: max-age=71090
    < Date: Tue, 26 Nov 2019 13:55:45 GMT
    < Connection: keep-alive
    <
    * Connection #0 to host xxxx.api.mailchimp.com left intact
    {"type":"akamai_error_message","title":"akamai_503","status":503,"ref_no":"Reference Number: 00.d5bbc217.1574776545.5567624"}

    Kindly advise the next steps.

    Thanks

    Plugin Author ryanhungate

    (@ryanhungate)

    @scody so this type of response means that your server has been blacklisted from the Akamai gateway – which is what sits in between your server, and the Mailchimp API. Considering you’ve done this with the raw CURL command in your SSH shell, we can most certainly rule out any PHP / WordPress / Plugin related issues is causing this.

    The next steps would be to move to a dedicated IP address for your site. Can you please reach out to your hosting provider, and plan for this type of DNS change? You will most likely have to change DNS records once they do the move, but that’s something you’ll need to discuss with your infrastructure / hosting provider etc.

    They’ll understand what you need from here, just let them know that your server’s IP address has been blacklisted and you need to take the proper steps to resolve it. This WILL resolve the connectivity issue 🙂

    Thanks and please feel free to follow up again if need be. We’re marking this as closed, because we’re positive this solution will solve your issue.

    503 Service Unavailable Mailchimp

    Dear Sir,

    I have an error with Woocommerce and Mailchimp. I have changed my
    domain provider, from Arsys to SiteGround, at Siteground also i have
    the hosting.

    The problem is that i can not use the contact form on my site, because
    Mailchimp is not connected with my WordPress.

    Could you please help me?

    I have bought a private IP at Siteground, but it is still not working.

    Thank you for your help.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.