Support » Plugin: Matomo Analytics - Ethical Stats. Powerful Insights. » mail without attachment while sending Matomo-report

  • Resolved volkhardv

    (@volkhardv)


    Hello,
    i´m using the plugn “Matomo Analytics – Ethical Stats. Powerful Insights.” V1.2.0 and want to use the mail-report functionality.
    i receive a mail – but not with an attachment. instead the is a body-text like (i´m using Outlook as a client):

    This is a message in Mime Format. If you see this, your mail reader does not support this format.

    –=75fc867fd90fc8389c9724ab18a57f2
    Content-Type: text/html; charset=f-8
    Content-Transfer-Encoding: quoted-printable
    Content-Disposition: inline

    <html style=”background-color:#edecec”>

    <head>
    <meta charset=”utf-8″>
    <meta name=”robots” content=”noindex,nofollow”>
    <meta name=”generator” content=”Matomo Analytics”>
    </head>

    <body style=”color:#212121;font-family:-apple-system, BlinkMacSystemFont, ‘Segoe UI’, Roboto, Oxygen-Sans, Cantarell, ‘Helvetica Neue’, sans-serif; line-height: 24px; margin:0 auto; max-width:1000px; background-color:rgb(255, 255, 255);box-shadow: 0px 0px 5px 1px rgba(0,0,0,0.75);”>

    <table style=”width:100%; background-color: #3450A3; color: #fff; padding:10px 0; margin: 0 0 25px 0; height:64px;”>
    <tr>
    <td>

    Matomo, Quelloffene Webanalytik

    </td>
    <td align=”right”>

    Dashboard

    </td>
    </tr>
    </table>

    <div style=”margin:0 20px;”>

    <h2 style=’color:#212121;font-family:-apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen-Sans, Cantarell, 'Helvetica Neue', sans-serif; color:#37474f; line-height:30px; margin:25px 0 15px 0;’>
    Hallo,
    </h2>

    <p style=’font-size:15px;line-height:24px;margin:0 0 16px;color:#212121;font-family:-apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen-Sans, Cantarell, 'Helvetica Neue', sans-serif;’>
    Sie finden Ihren wöchentlich Bericht für Demo Obi Internet in der angehängten Datei.
    <br />Bericht Demo Obi Internet – Donnerstag, 27. August 2020
    <br />Zeitspanne: Donnerstag, 27. August 2020
    <br />Gesendet von https://customer.vogeler-ag.de/obi/internet/wp-content/plugins/matomo/app/
    </p>

    <hr style=” border: 0; margin-top: 50px; height: 1px; background-image: linear-gradient(to right, rgba(231, 231, 231, 0), rgba(231, 231, 231, 1), rgba(2311, 2311, 231, 0));”>

    <p style=’font-size:15px;line-height:24px;margin:0 0 16px;color:#212121;font-family:-apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen-Sans, Cantarell, 'Helvetica Neue', sans-serif;text-align:center;font-size:13px; color:#666;padding-top:30px;margin-bottom:0;’>
    Powered by
    Matomo Analytics
    <br />
    Die führende Open-Source-Analyseplattform, die Ihre Privatsphäre achtet.
    </p>

    <p style=’font-size:15px;line-height:24px;margin:0 0 16px;color:#212121;font-family:-apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen-Sans, Cantarell, 'Helvetica Neue', sans-serif;text-align:center;font-size:13px; color:#666;’>Um sich von diesem Bericht abzumelden, klicken Sie bitte folgenden Link: Abmelden.</p>

    </div>
    </body>
    </html>

    –=75fc867fd90fc8389c9724ab18a57f2
    :
    :
    –=75fc867fd90fc8389c9724ab18a57f2–

    when i configure another smtp-Server i get an “data not accepted”-error.

    can anyone help?

    best regards

    Volkhard

    • This topic was modified 1 year, 1 month ago by volkhardv.
Viewing 14 replies - 16 through 29 (of 29 total)
  • Thread Starter volkhardv

    (@volkhardv)

    Hello Thomas,

    i added that line – but it didn´t help….

    best regards

    volkhard

    Plugin Author Thomas

    (@tsteur)

    Just to keep you updated @volkhardv I’ve been troubleshooting this and signed up for an office 365 account. I’ve kind of found the problem but not sure yet if/how I can workaround it as it’s a problem in the PHP Mailer library that WordPress is using. I’ll keep you updated.

    Thread Starter volkhardv

    (@volkhardv)

    Hello Thomas,

    thanks for your support and help! 🙂

    best regards

    Volkhard

    Plugin Author Thomas

    (@tsteur)

    Hi @volkhardv

    we have noticed the bug is really in the PHPMailer library that WordPress is using to send emails. We have created an issue to let them know and explained the problem in detail here: https://github.com/PHPMailer/PHPMailer/issues/2134

    We have also created an internal issue for us here: https://github.com/matomo-org/wp-matomo/issues/347

    As of right now there isn’t really anything more we can do but waiting to see what the people at PHPMailer say and hoping they fix it and WordPress to eventually include that fix. This could be all a quite long procedure unfortunately.

    So far this seems to mostly only impact Outlook in Office 365 as we haven’t seen the issue anywhere else yet. Do you mind if we resolve this issue for now and we keep track of this in our internal issue where we will proceed when/if needed?

    Sorry I don’t have better news right now. The only workaround right now be to use the reports maybe without PDF and instead choose “HTML” in the email report.

    Plugin Author Thomas

    (@tsteur)

    Just wanted to keep you updated that we’ll very likely fix this as part of our Matomo 4 update in about 2 months time. We’ll be trying to change how we’re sending emails quite a bit and hoping that it will be possible to workaround this issues then.

    Thread Starter volkhardv

    (@volkhardv)

    Hello Thomas,

    thanks a lot for your analysis, support and engagement 🙂
    we should follow your plan closing the ticket and keeping track internally.

    best regards!

    Volkhard

    Plugin Author Thomas

    (@tsteur)

    Thanks. I’ll comment here once it’s done.

    Plugin Author Thomas

    (@tsteur)

    Hi @volkhardv

    just wanted to keep you updated that our next big major release contains a fix for this. We verified and it works with Office 365. This release will be still roughly 2 months away though. T

    Thread Starter volkhardv

    (@volkhardv)

    Hi Thomas,

    thanks for this information, fixing and your engagement.
    I´ll wait for this release 🙂

    best reggards

    Volkhard

    Thanks to all. Our Clients are also waiting for that release 🙂

    W.INGS

    (@wings-1)

    Thank you. I have no Office 365 mail but i have tested it on a Gmail account, a custom IMAP account and a ProtonMail account. On all of these accounts is the same issue. I hope the fix will help on this…

    Thread Starter volkhardv

    (@volkhardv)

    Hello Thomas,
    hope all things go well 🙂

    Sorry for asking: do you know, when you will release the fix for this issue?

    best regards

    volkhard

    Plugin Author Thomas

    (@tsteur)

    Hi @volkhardv doing very well here and hoping you are too 🙂

    We’re planning to release Matomo 4 in about 2 weeks. I’ll then wait likely for one more week in case there are any issues with this new major release before releasing this update here. So roughly 3 weeks. I hope this helps 🙂

    Thread Starter volkhardv

    (@volkhardv)

    Hello Thomas,

    thanks:)
    everything is okay.

    best regards

    Volkhard

Viewing 14 replies - 16 through 29 (of 29 total)
  • The topic ‘mail without attachment while sending Matomo-report’ is closed to new replies.