WordPress.org

Support

Support » Plugins and Hacks » Postie » [Resolved] Mail server error since last update

[Resolved] Mail server error since last update

  • Hello,

    since last update postie can’t get to connect to my mail server.
    Error_log says:

    [21-Jun-2013 07:47:13] Postie: Connecting to mail.xxxx:993 (imap-ssl)
    [21-Jun-2013 07:47:13] PHP Warning: Wrong parameter count for imap_open() in /home1/xxx/public_html/wp-content/plugins/postie/postieIMAP.php on line 83
    [21-Jun-2013 07:47:13] Postie: imap_open failed:
    [21-Jun-2013 07:47:13] Postie: Mail Connection Time Out
    [21-Jun-2013 07:47:13] Postie: Common Reasons: Server Down, Network Issue, Port/Protocol MisMatch
    [21-Jun-2013 07:47:13] Postie: The Server said:
    [21-Jun-2013 07:47:13] PHP Warning: imap_close(): supplied argument is not a valid imap resource in /home1/xxx/public_html/wp-content/plugins/postie/postieIMAP.php on line 150
    [21-Jun-2013 07:47:13] Postie: There are 0 messages to process

    http://wordpress.org/extend/plugins/postie/

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Wayne Allen

    @wayneallen-1

    What version of PHP are you using?

    Hi Wayne,

    I am having the exactly same problem …. and it started when I updated the PHP from version 5.2 to 5.3.2.

    Is the plugin not compatible

    Thanks

    Plugin Author Wayne Allen

    @wayneallen-1

    Looks like the new feature I added for MS Exchange mail servers is only available after PHP 5.3.2. I’ll add a check and get a fix out.

    How can I see what PHP version I have?

    Plugin Author Wayne Allen

    @wayneallen-1

    This will be fixed in 1.5.14

    Hi,

    after updating to 1.5.14 I get these errors:

    [Wed Jun 26 04:42:37 2013] [error] [client xxxxx] PHP Warning: require_once(/usr/share/pear/PEAR.php) [function.require-once]: failed to open stream: Permission denied in /nas/wp/www/cluster-1493/xxx/wp-content/plugins/postie/mimedecode.php on line 66, referer: http://xxx/wp-admin/options-general.php?page=postie/postie.php
    [Wed Jun 26 04:42:37 2013] [error] [client xxxxxx] PHP Fatal error: require_once() [function.require]: Failed opening required ‘PEAR.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /nas/wp/www/cluster-1493/xxxx/wp-content/plugins/postie/mimedecode.php on line 66, referer: http://xxxxx/wp-admin/options-general.php?page=postie/postie.php

    Plugin Author Wayne Allen

    @wayneallen-1

    That is an odd error. Please try
    1) reinstalling Postie
    2) verify file permissions
    3) verify file exists

    Let me know what you find.

    Is there a way to save all my config before delete and reinstall the plugin?

    Plugin Author Wayne Allen

    @wayneallen-1

    Deleting the plugin will not delete your settings.

    Deleting and reinstalling the plugin didn’t help.

    Can you be more specific with
    2) verify file permissions
    3) verify file exists
    ?

    Thank you

    Plugin Author Wayne Allen

    @wayneallen-1

    If you’d like me to take a look at your system please contact me at postie-help@devzing.com

    Hi,

    after I talked with my hosting (wpengine) support team, this is what I have been told:

    Hi tradeasy —

    I’ve just discussed this with one of our systems administrators who was able to confirm that we do not have PHP pear installed on our infrastructure. We are currently looking into the possibility of doing so, however, it would be more of a long term project and not something that we are able to do immediately.

    Presently, it doesn’t appear that any functionality that uses pear would be able to function on our platform.

    We apologize for the inconvenience.

    Plugin Author Wayne Allen

    @wayneallen-1

    I don’t think you need PHP pear installed, the error was about a missing file that is included in the plugin.

    Hey, i am having very similar problem with Postie, just upgraded to Postie from PostByEmail and Postie is much better.

    this is the error i get:

    Warning: require_once() [function.require-once]: SAFE MODE Restriction in effect. The script whose uid is 5056 is not allowed to access /usr/lib/php/PEAR.php owned by uid 0 in /home/fdonscom/public_html/wp-content/plugins/postie/mimedecode.php on line 66

    Warning: require_once(/usr/lib/php/PEAR.php) [function.require-once]: failed to open stream: No such file or directory in /home/fdonscom/public_html/wp-content/plugins/postie/mimedecode.php on line 66

    Fatal error: require_once() [function.require]: Failed opening required ‘PEAR.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/fdonscom/public_html/wp-content/plugins/postie/mimedecode.php on line 66

    The Pear.php file exists and permissions are correct on it.

    is there a fix for it?

    Plugin Author Wayne Allen

    @wayneallen-1

    It looks like you have 2 copies of PEAR.php. One in /home/fdonscom/public_html/wp-content/plugins/postie/ and one in /usr/lib/php/

    It is the second one that is causing the problem. Please check the permissions on /usr/lib/php/PEAR.php

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] Mail server error since last update’ is closed to new replies.
Skip to toolbar