Support » Plugin: WP Mail SMTP by WPForms » Mail sending error

  • Resolved captanr333

    (@captanr333)


    There was a problem while sending a test email. Related debugging output is shown below:

    Versions:
    WordPress: 4.9.1
    WordPress MS: No
    PHP: 5.4.45
    WP Mail SMTP: 1.2.2

    Params:
    Mailer: mail
    Constants: No

    Server:
    PHP.mail(): Yes
    Apache.mod_security: No

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Slava Abakumov

    (@slaffik)

    @captanr333

    As far as I can see you have not set the SMTP at all.

    Currently, to make things work you definitely need not only activate the plugin but to configure it as well.

    Please refer to a plugin readme here on a repository to get links to our tutorials to configure Gmail/SendGrid/Mailgun/SMTP: https://wordpress.org/plugins/wp-mail-smtp/

    captanr333

    (@captanr333)

    There was a problem while sending a test email. Related debugging output is shown below:

    Versions:
    WordPress: 4.9.1
    WordPress MS: No
    PHP: 5.4.45
    WP Mail SMTP: 1.2.2

    Params:
    Mailer: smtp
    Constants: No
    ErrorInfo: SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting
    Host: info@xyz.com
    Port: 465
    SMTPSecure: tls
    SMTPAutoTLS: bool(true)
    SMTPAuth: bool(true)

    Server:
    OpenSSL: Yes
    Apache.mod_security: No
    SMTP Debug:
    2018-01-03 18:21:27 SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

    • This reply was modified 3 years ago by captanr333.
    Plugin Author Slava Abakumov

    (@slaffik)

    @captanr333

    I see that you have edited the SMTP Debug:. Please post it here without changes.

    Also, SMTP Host is not an email, it’s a domain name, like smtp.google.com. That might be your problem.

    I have this error what will I do

    Versions:
    WordPress: 4.9.4
    WordPress MS: No
    PHP: 5.6.31
    WP Mail SMTP: 1.2.5

    Params:
    Mailer: mail
    Constants: No

    Server:
    PHP.mail(): Yes
    Apache.mod_security: No

    • This reply was modified 2 years, 11 months ago by rahulp34.
    Plugin Author Slava Abakumov

    (@slaffik)

    @rahulp34

    As far as I can see, you have not configured the plugin at all (Mailer: mail).

    Please visit this page: https://wordpress.org/plugins/wp-mail-smtp/ – and read the possible mailers that you can use to send emails. There will be links to configure any of them.

    You need to switch from Default (none) mailer to anything else in plugin settings.

    Добрый день!

    Ошибка такая же, как и у всех:

    Versions:
    WordPress: 4.9.4
    WordPress MS: No
    PHP: 7.0.20
    WP Mail SMTP: 1.2.5

    Params:
    Mailer: mail
    Constants: No

    Server:
    PHP.mail(): Yes
    Apache.mod_security: No

    Что необходимо сделать, при условии что ни одна форма не работает, т.е. не отсылает письма? Помогите, пожалуйста.

    There was a problem while sending a test email. Related debugging output is shown below:

    Versions:
    WordPress: 4.9.4
    WordPress MS: Yes
    PHP: 7.0.23
    WP Mail SMTP: 1.2.5

    Params:
    Mailer: smtp
    Constants: Yes
    ErrorInfo: SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting
    Host: agrihomegh.com
    Port: 465
    SMTPSecure: ssl
    SMTPAutoTLS: bool(false)
    SMTPAuth: bool(true)

    Server:
    OpenSSL: Yes
    Apache.mod_security: No
    SMTP Debug:
    2018-03-31 09:06:49 Connection: opening to ssl://agrihomegh.com:465, timeout=300, options=array (
    )
    2018-03-31 09:06:49 Connection: Failed to connect to server. Error number 2. “Error notice: stream_socket_client(): SSL operation failed with code 1. OpenSSL Error messages:
    error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
    2018-03-31 09:06:49 Connection: Failed to connect to server. Error number 2. “Error notice: stream_socket_client(): Failed to enable crypto
    2018-03-31 09:06:49 Connection: Failed to connect to server. Error number 2. “Error notice: stream_socket_client(): unable to connect to ssl://agrihomegh.com:465 (Unknown error)
    2018-03-31 09:06:49 SMTP ERROR: Failed to connect to server: (0)
    2018-03-31 09:06:49 SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

    Plugin Author Slava Abakumov

    (@slaffik)

    @adcreat

    Ответ такой же, как и всем 🙂

    As far as I can see, you have not configured the plugin at all (Mailer: mail).

    Please visit this page: https://wordpress.org/plugins/wp-mail-smtp/ – and read the possible mailers that you can use to send emails. There will be links to configure any of them.

    You need to switch from Default (none) mailer to anything else in plugin settings.

    Вам надо просто настроить плагин, почитайте его описание.

    ——

    @coach-afrane

    Something with the certificate on a server. Please contact your hosting company support to investigate the issue. You can provide them the Debug output.

    There was a problem while sending a test email. Related debugging output is shown below:

    Versions:
    WordPress: 4.9.5
    WordPress MS: No
    PHP: 5.6.31
    WP Mail SMTP: 1.2.5

    Params:
    Mailer: smtp
    Constants: No
    ErrorInfo: SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting
    Host: smtp.yandex.com
    Port: 465
    SMTPSecure: tls
    SMTPAutoTLS: bool(true)
    SMTPAuth: bool(true)

    Server:
    OpenSSL: Yes
    Apache.mod_security: No
    SMTP Debug:
    2018-04-27 12:21:51 Connection: opening to smtp.yandex.com:465, timeout=300, options=array (
    )
    2018-04-27 12:21:56 Connection: Failed to connect to server. Error number 2. “Error notice: stream_socket_client(): unable to connect to smtp.yandex.com:465 (Network is unreachable)
    2018-04-27 12:21:56 SMTP ERROR: Failed to connect to server: Network is unreachable (101)
    2018-04-27 12:21:56 SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

    I got the following error, someone could help me…
    Versions:
    WordPress: 4.9.5
    WordPress MS: No
    PHP: 7.0.1
    WP Mail SMTP: 1.2.5

    Params:
    Mailer: smtp
    Constants: No
    ErrorInfo: SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting
    Host: smtp.gmail.com
    Port: 587
    SMTPSecure: tls
    SMTPAutoTLS: bool(true)
    SMTPAuth: bool(true)

    Server:
    OpenSSL: Yes
    Apache.mod_security: No
    SMTP Debug:
    2018-05-16 18:55:07 Connection: opening to smtp.gmail.com:587, timeout=300, options=array (
    )
    2018-05-16 18:55:07 Connection: Failed to connect to server. Error number 2. “Error notice: stream_socket_client(): php_network_getaddresses: getaddrinfo failed: No such host is known.
    2018-05-16 18:55:07 Connection: Failed to connect to server. Error number 2. “Error notice: stream_socket_client(): unable to connect to smtp.gmail.com:587 (php_network_getaddresses: getaddrinfo failed: No such host is known. )
    2018-05-16 18:55:07 SMTP ERROR: Failed to connect to server: php_network_getaddresses: getaddrinfo failed: No such host is known. (0)
    2018-05-16 18:55:07 SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

    Hi all,

    I have an issue with below. Can anybody help?

    There was a problem while sending a test email. Related debugging output is shown below:

    Versions:
    WordPress: 4.9.6
    WordPress MS: No
    PHP: 5.4.16
    WP Mail SMTP: 1.2.5

    Params:
    Mailer: mailgun
    Constants: No
    Api Key / Domain: Yes
    Please copy only the content of the error debug message above, identified with an orange left border, into the support forum topic if you experience any issues.

    I have configured wp smtp but i get the following error.

    Versions:
    WordPress: 4.9.6
    WordPress MS: No
    PHP: 5.6.36
    WP Mail SMTP: 1.2.5

    Params:
    Mailer: smtp
    Constants: No
    ErrorInfo: SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting
    Host: smtp.yandex.com.tr
    Port: 465
    SMTPSecure: ssl
    SMTPAutoTLS: bool(false)
    SMTPAuth: bool(true)

    Server:
    OpenSSL: Yes
    SMTP Debug:
    2018-06-07 10:43:13 Connection: opening to ssl://smtp.yandex.com.tr:465, timeout=300, options=array (
    )
    2018-06-07 10:43:13 Connection: Failed to connect to server. Error number 2. “Error notice: stream_socket_client(): SSL operation failed with code 1. OpenSSL Error messages:
    error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
    2018-06-07 10:43:13 Connection: Failed to connect to server. Error number 2. “Error notice: stream_socket_client(): Failed to enable crypto
    2018-06-07 10:43:13 Connection: Failed to connect to server. Error number 2. “Error notice: stream_socket_client(): unable to connect to ssl://smtp.yandex.com.tr:465 (Unknown error)
    2018-06-07 10:43:13 SMTP ERROR: Failed to connect to server: (0)
    2018-06-07 10:43:13 SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

    ersions:
    WordPress: 4.9.6
    WordPress MS: No
    PHP: 7.2.7
    WP Mail SMTP: 1.3.3

    Params:
    Mailer: smtp
    Constants: No
    ErrorInfo: SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting
    Host: mail.promiba.com
    Port: 587
    SMTPSecure: tls
    SMTPAutoTLS: bool(false)
    SMTPAuth: bool(true)

    Server:
    OpenSSL: Yes
    Apache.mod_security: No
    SMTP Debug:

    2018-07-20 09:42:55 Connection: opening to mail.promiba.com:587, timeout=300, options=array (
    )
    2018-07-20 09:42:56 Connection: opened
    2018-07-20 09:42:56 SERVER -> CLIENT: 220 SurgeSMTP (Version 7.3e2-2) http://surgemail.com
    2018-07-20 09:42:56 CLIENT -> SERVER: EHLO promiba.com
    2018-07-20 09:42:56 SERVER -> CLIENT: 250-. Hello promiba.com (94.73.151.87)
    250-AUTH LOGIN PLAIN
    250-ETRN
    250-STARTTLS
    250-X-ID 636c7573746572333070726f7879312e6e6174726f686f73742e636f6d31393939323331303538
    250-SIZE 50000000
    250 HELP
    2018-07-20 09:42:56 CLIENT -> SERVER: STARTTLS
    2018-07-20 09:42:56 SERVER -> CLIENT: 220 go ahead, begin SSL/TLS negotiation
    2018-07-20 09:42:56 SMTP Error: Could not connect to SMTP host.
    2018-07-20 09:42:56 CLIENT -> SERVER: QUIT
    2018-07-20 09:42:56 SERVER -> CLIENT: �2�Ʌ��a[�����@����&?�
    2018-07-20 09:42:56 SMTP ERROR: QUIT command failed: �2�Ʌ��a[�����@����&?�
    2018-07-20 09:42:56 Connection: closed
    2018-07-20 09:42:56 SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

    ı have the above problem . ı have used different smtp pluguins to allow contact form 7 but still no solution

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Mail sending error’ is closed to new replies.