Support » Plugin: MailPoet Newsletters (Previous) » Mail Poet Newsletters Php 7 Compatibility

  • Hiya, I’m thinking about updating my site to use Php 7 and was just wondering if this would cause any problems with this plugin?

    Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • I did not work on our website, I tested it yesterday.

    We are thinking about rolling back to 5.6 even with the performance losses.

    Many plugins are having strange issues with PHP 7.

    WordPress is recommending 5.6 and probably won’t recommend 7 until mid 2017.

    So if you can live with the slow performances of PHP 5.6 I would suggest staying on 5.6 until WordPress recommend PHP 7.

    Which should force many plugins to really test for 7.

    Plugin Author MailPoet

    (@wysija)

    Hi,

    We have a lot of users already using MailPoet with PHP7.

    If you have any issues, please report them, as we will look into them as soon as possible.

    Hi, I tried with my hosting (Siteground) to test PHP 7 but returns an error with the plugin MailPoet

    FILE: … / public_html / xxx.xx / wp-content / plugins / wysija-newsletters / helpers / bounce.php
    ————————————————– ————————————————– —
    FOUND 0 1 ERRORS AND WARNING Affecting 1 LINE
    ————————————————– ————————————————– —
      63 | WARNING | Function dl () is deprecated since PHP 5.3
    ————————————————– ————————————————– —

    FILE: … / public_html / xxx.xx / wp-content / plugins / plugins / wysija-newsletters / inc / pear / pear.php

      754 | WARNING | Function dl () is deprecated since PHP 5.3
      754 | WARNING | Function dl () is deprecated since PHP 5.3
      852 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.

    same here. I got PHP 7 Error report for the following plugins from SitegRound.

    The following plugins/themes are not compatible with PHP 7.0.
    MailPoet Newsletters
    PuSHPress
    WPBakery Visual Composer

    For MailPoet this is the error:

    FILE: /home/axxxx/public_html/wp-content/plugins/wysija-newsletters/helpers/bounce.php
    ————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————-
    63 | WARNING | Function dl() is deprecated since PHP 5.3
    ————————————————————————-

    FILE: /home/axxxx/public_html/wp-content/plugins/wysija-newsletters/inc/pear/pear.php

    754 | WARNING | Function dl() is deprecated since PHP 5.3
    754 | WARNING | Function dl() is deprecated since PHP 5.3
    852 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ——————————————————————–

    Emily G

    (@genevish-graphics)

    Same here. Whats the status on this? I am a pro user so I guess I will post a ticket

    Same here

    pear.php
    ————————————————————————————————-
    FOUND 0 ERRORS AND 5 WARNINGS AFFECTING 4 LINES
    ————————————————————————————————-
    171 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    740 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    754 | WARNING | Function dl() is deprecated since PHP 5.3
    754 | WARNING | Function dl() is deprecated since PHP 5.3
    852 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ————————————————————————————————-

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Mail Poet Newsletters Php 7 Compatibility’ is closed to new replies.