Support » Plugin: Contact Form by WPForms - Drag & Drop Form Builder for WordPress » mail delivery i am lost after trying all your guides

  • Resolved gavpedz

    (@gavpedz)


    Hello.

    I am having real issue here with email being delivered.
    Before we start please not i do use your paid version on my own site and the email delivers just fine with no issue at all.

    i have recently set up a site for someone using the free version or WPFORMS now for this site email is not delivered.

    For both my site and this new one i use zoho mail to host our email. Oddly i don’t have to specify this on my site as email works fine.

    On the new site i have tried the smtp plugin and specified zoho’s smtp settings. I have set from email address in both smtp settings and form as the email i also want to receive these notifications but still not working. Running a test email on the smtp plugin shows as true and email works and i get it. But the form does not send emails. What am i missing i have tried everything.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Interestingly if i will out the contact form and in the email field put the email address that the form is being sent from i get the notification any other email in the form does not work. Note I have tried several emails form different providers in the form

    Just installed pirate forms to test and worked first time so whats happening with WPForms? I prefer wpforms and want to use it so with my tests it seems it is something specific to this form.

    Plugin Author Jared Atchison

    (@jaredatch)

    Hey gavpedz,

    Thanks for reaching out! Sorry to hear you’re having some email delivery issues.

    I believe the issue is likely the “From Email” notification field. By default on most forms this is {field_id="1"} (or similar) which means it sends “from” whatever email the user provides in the form.

    The problem is this setting often causes issues when using an SMTP provider. If the email tries to send from an email that is not the SMTP email account address, they’ll consider that spam and the email doesn’t go through. Google, Yahoo, Hotmail all do this so there is a good chance Zoho might to. Changed that “From Email” field to your zoho email address SMTP is configured to use may resolve the issue. Then you would just want to move the smart tag ({field_id="1"}) to the Reply-To field below it.

    Let me know if that helps!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘mail delivery i am lost after trying all your guides’ is closed to new replies.