Support » Fixing WordPress » Magically delicious custom fields – create themselves!

  • What I wanted to do was combine 2 of my blogs, and switch to a magazine style theme for both. I needed a development blog so I installed 2.6 in a directory in my root on a spare database I had lying around. Then I upgraded both the old blogs to 2.6 using the auto update plugin. I then imported both into the newly created brand new 2.6 development blog. I briefly lost my categories, but searched and found a solution to that, and all seemed well. The plan was to develop this joint blog and when it was done I’d redirect my domain.

    The magazine style theme I chose relies heavily on custom field images on the main page. I’m having two problems with customs fields. First, none of the images that I specify as the value show up in the custom fields. I’ve been editing previously published posts, and I tried both relative links and the full string, and nada. I went back to the codex and read about the-meta template tag (though there was not a word nothing about needing this in the theme tutorials) and I added the-meta tag in my posts, and still nothing. On the main page a box displays where the custom field should be, and it contains the name of the custom field, but no image. The images display fine in the post itself.

    Since I’d been adding custom fields to previously published posts, I thought I maybe I should try adding them to new posts. That didn’t work with the custom field images either, and I noticed something else that is my second problem. Under Write >Post what I found were custom enclosure fields already created (even though I’ve never defined enclosure fields) for every instance of mp3 files linked to in the blog. It’s a blog I use for my podcast , so that’s quite a few.

    So there are now about 75 custom fields already there when I write a new post, and I can’t seem to delete the suckers. I’ve tried, but they just move to the bottom of the pile, and when I get to the end, I’m back at enclosure #1. They don’t seem to be showing up on the main page, or in the post itself, but I assume the list will continue to grow as I add mp3 podcast content. Surely this can’t be right. Bottom line, I don’t even need enclosures as I don’t use the blog feed for my podcast, I write a separate feed for that. Can the enclosures be disabled?

    With regard to the theme, I’ve contacted the theme author, and he’s running this theme just fine on 2.6, so I’m stumped. I’ve never encountered anything like this before. I’d appreciate any feedback, help, tips or suggestions.

    Thanks much.

  • The topic ‘Magically delicious custom fields – create themselves!’ is closed to new replies.