Support » Fixing WordPress » Magic quotes won’t turn off in WordPress

  • I set ‘magic_quotes_gpc = Off’ in the php.ini file on my server. For all of my non-WordPress sites, magic quotes are turned off correctly. I also checked the PHP settings on my server to verify that magic quotes are turned off.

    On my WordPress site, however, magic quotes are not turned off. When I fill out a form and type quotes in the input fields, for example, the email I receive back returns slashes.

    How do I turn off magic quotes in WordPress?

Viewing 3 replies - 1 through 3 (of 3 total)
  • monkeymartin@gmail.com

    (@monkeymartingmailcom)

    Your php.ini file has to be in each directory that has php files. Or you have to change the the main php.ini file

    You can use phpinfo() to find your global php.ini file

    Your php info page should look like this

    The link

    robbin_g

    (@robbin_g)

    where do I find the php info page?

    Compelete newbie with this issue monkeying with my theme…

    Mark Ratledge

    (@songdogtech)

    Make a plain text file and call it phpinfo.php and then put just this line in it:

    <?php php_info(); ?>

    then put it in the root of your server, and then go to that file with your web browser. You’l see all the php info you need, or if you get an error, that means your server company won’t allow php_info to run for security reasons.

    To turn off smart quotes, try this plugin.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Magic quotes won’t turn off in WordPress’ is closed to new replies.