Support » Plugins and Hacks » [Plugin: Magic Fields] Magic Fields won't display

[Plugin: Magic Fields] Magic Fields won't display

  • I am setting up a WordPress multi-user installation for a client and have everything set up, and he is looking to use Magic Fields v1 to get custom fields displayed on a modified version of Twenty Eleven.

    I have created a custom write panel named “Create Capture Page” with the following fields (by name, not label):


    They’re both multiline textboxes, but I can’t seem to get them to display in my Twenty Eleven child theme. I’m putting the following code in the file “sidebar-page.php”:

    <?php echo get('body'); ?>

    Nothing is showing up though. If you need to see the webpage or anything else I would be happy to. If anybody could help me out though I would very much appreciate it.


Viewing 5 replies - 1 through 5 (of 5 total)
  • I’m only gonna bump this once. Anybody have any pointers to help me out?

    Don’t know if Magic-Fields team is on this issue but in the mean time you can solve it by using WordPress native custom fields methods:

    get_post_meta ( $post->ID, ‘my_magic-fields-var-name’, true );

    You will still have problems with groups and images

    While there’s not an update for magic-fields could someone help on
    how to get around the image request with or without crop and re-size?

    I just downgraded to 3.2.1 to get the plugin to work… but I was just curious as to why it wouldn’t work with 3.3.

    I did a debugging to find out what was causing this.
    And i found an incompatibility on tables collation.

    I changed this tables to utf8_unicode_ci:

    And this field:
    field_name from table wp_mf_post_meta.

    I tested the functions get and get_image and now works fine.

    Tested on:
    Mysql = 5.5.8
    WP = 3.3.1
    MF =

    Best regards!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Magic Fields] Magic Fields won't display’ is closed to new replies.