WordPress.org

Support

Support » Themes and Templates » Magazine Basic – Can’t Upload Header Image

Magazine Basic – Can’t Upload Header Image

  • Hi, I’m a newby… delighted with the Magazine Basic theme! But can’t seem to upload an image for the header.
    I am getting the following message:

    Warning: getimagesize() [function.getimagesize]: URL file-access is disabled in the server configuration in …/functions.php on line 108

    Warning: getimagesize(http://geneva.usmission.gov/news/wp-content/themes/magazine-basic/uploads/testBack.jpg) [function.getimagesize]: failed to open stream: no suitable wrapper could be found in …/functions.php on line 108

    Also, I’m wondering where I can find the optimal pixel dimensions to fill the header space. It’s probably somewhere obvious, but I’m missing it!

Viewing 15 replies - 1 through 15 (of 19 total)
  • esmi
    Forum Moderator

    @esmi

    I don’t know this theme at all but, looking at the error messages you’re getting, the first thing that occurs is – have you checked that testBack.jpg uploaded correctly?

    What is testBack.jpg and where should I look for it?

    Oops, that was really silly of me, I forgot that I had named the graphic “testBack”… sorry,

    So I’ve just looked in uploads under the Magazine Theme, and also the general Uploads for the site, and it is not in either directory. (Normally where is it supposed to go?)

    Here’s what happens when I get this message… the image does appear in the topper, but it appears with the java script above written over it. So then I deactivate the choice of using a graphic, and it disappear….

    I’ve also checked the file permissions on the folders and the functions.php file above and all should be writeable.

    esmi
    Forum Moderator

    @esmi

    The Magazine theme appears to be looking in wp-content/themes/magazine-basic/uploads so that’s where you need to upload any header image.

    It’s in that directory, but still doesn’t work!

    c.bavota
    Member

    @tinkerpriest

    Hey WendyWeb,

    Do you know if you are on a Windows server? I know a lot of people have been having issues with the header uploader on Windows servers. If you want to contact me with more info I will take a look and see what the problem is. Just go to my site’s contact page and drop me an email. Any solution I find I will post back here as well.

    affectiveartistry
    Member

    @affectiveartistry

    It’s looking for a specifically named file. When I created the upload folder under the theme’s main folder and uploaded my header image there named logo.gif it worked. Just uploading any header graphic from the dashboard won’t work.

    Hmm, that sounds like it could have worked, but I’ve already used another solution suggested by the theme’s designer – I have commented out the following line in the header.php.

    /* if (get_option(‘uwc_logo_header’) == “yes”) {
    list($w, $h) = getimagesize(get_option(‘uwc_logo’));
    $height = $h/2+20;
    } else {
    $height= 35;
    }*/

    This also worked and now my header – which is not named logo — is inserted in the banner space.

    innersanctum
    Member

    @innersanctum

    Wendy, thanks for the information but I didn’t find this in the header.php file but actually in the functions.php file and once I did what you said it works perfectly.

    Thanks for leading me to the water and let me drink on my own.

    Yes, that’s right, it’s in the functions.php file.

    And just a note, as an experiment, I did try renaming the file logo.jpg and uploading it, but that did not work. Only commenting out the script above worked.

    The code that needs to be hidden starts on line 107 of the functions.php document

    I blocked out the code as advised on this site. I still cant upload a header graphic and now get this text above my header: Warning: getimagesize(http://www.webaddress.com/wp-content/themes/magazine-basic/uploads/logo_72dpi.jpg) [function.getimagesize]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in /home/public_html/wp-content/themes/magazine-basic/functions.php on line 108

    I can now upload pictures. I went to miscelaneous settings and unchecked the options so nothing is selected. Then I saved and was able to upload a photo to a story. BUT I get this code appearing above my header image:
    Warning: getimagesize(http://www.mywebsite.com/wp-content/themes/magazine-basic/uploads/logo_72dpi.jpg) [function.getimagesize]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in /home/public_html/ppp/wp-content/themes/magazine-basic/functions.php on line 108

    Getting a bit tired of it all now…

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Magazine Basic – Can’t Upload Header Image’ is closed to new replies.