Magaling theme with Featured Content Gallery and timthumb problem (8 posts)

  1. nflsfrankjohnray
    Posted 6 years ago #


    I started using Magaling theme and followed its instruction

    But I had no luck with it's Featured Content Gallery and thumbnail image(timthumb)

    FCG shows this error message:
    Warning: include() [function.include]: Failed opening '/home/bodymyst/public_html//wp-content/plugins/content-gallery/gallery.php' for inclusion (include_path='.:/usr/local/php52/pear') in /home/bodymyst/public_html/wp-content/themes/magaling/index.php on line 8

    and thumbnail image of post just never shows up (despite I tried on localhost which is xampp and it worked fine)

    It drove me crazy to try to find solution for this, so I am begging for help. My website is seoblogmoney.com.

    It will be really really really appreciate if you can help me with this, thank you so much.

    Best regards and big thanks


  2. jceresini
    Posted 6 years ago #

    Does that file exist. It appears it does not. Login to your blog via FTP and browse to /home/bodymyst/public_html/wp-content/plugins/

    That is the folder you will need to upload the content-gallery, popularity-contest and twitter-for-wordpress folders to, from the instructions page.

    [signature moderated Please read the Forum Rules]

  3. nflsfrankjohnray
    Posted 6 years ago #

    Hi jceresini,

    I think the plugin is fine, everything is installed and updated.

    However, (include_path='.:/usr/local/php52/pear'), this is the crucial part that cannot be executed, because of some php version issue I guess.

  4. nflsfrankjohnray
    Posted 6 years ago #

    Anybody help please :S

  5. jceresini
    Posted 6 years ago #

    The include path is what php uses to find a file you include, if its given a relative path. For example, the "." in the include path indicates that php shoudl first look in the current directory. So if file1.php includes "file2.php" it will try to find it in the same folder file1.php is in. However, the plugin is not using a relative path. You can tell this because it begins with a forward-slash. Since its an absolute path, starting at the root of the server, the include path is pretty much ignored.

    If the file does exist in that path (/home/bodymyst/public_html//wp-content/plugins/content-gallery/gallery.php) you may want to make sure that the permissions on the file, and the directories it's contained in are sufficient for php to read them.

  6. nflsfrankjohnray
    Posted 6 years ago #

    Thanks Jceresini,

    I've resolved the problem with Feature Content Gallery, the problem was the path in index should be /plugins/featured-content-gallery/gallery.php, and I didn't notice that. :D

    However, I am still not able to sort the timthumb problem out, both script and cache folder's permission are set to 777, seems there is nothing else I can do but to email my hosting provider.(it works fine on my xampp localhost)

  7. nflsfrankjohnray
    Posted 6 years ago #

    Still cannot sort out the thumbnail problem :S

    Really frustrating

  8. MaxiesGal
    Posted 6 years ago #

    Hey Frank,

    Would the double slash // between 'public_html//wp-content' be causing the problem ?


    Fellow Magaling theme user, who is ecstatic about the theme, but about to run over a small child at the complete lack of support or a forum or sumptin' ... I'm just getting started http://www.maxbaer.org/mb/

Topic Closed

This topic has been closed to new replies.

About this Topic