WordPress.org

Support

Support » Installation » made MySQL updates but still doesn’t work

made MySQL updates but still doesn’t work

Viewing 6 replies - 1 through 6 (of 6 total)
  • I’m having the same problem. Running PHP v. 4.3.10 (probably no php problem), mysql v. 4.0.27. on FreeBSD 4.7. The mysql resides at usr/local/mysql and has the database I made for WordPress. I have triple-checked everything else in the WordPress installation steps and can find nothing incorrect.

    Yet when I run wp-admin/install.php I get the same message as PB gets:

    “Your PHP installation appears to be missing the MySQL which is required for WordPress.”

    Having PHP and MySQL installed both – is not the same as having them to “talk” to each other, i.e. to be able to communicate.

    If this happens on your own machine and not in a hosted environment, try to seek help in a specialized forum. We do NOT offer help for server setup.

    Thanks for taking the time to point out the obvious, Moshu, while offering no help. The fact that WordPress requires MySQL tells me that someone should be willing to offer at least a small amount of help in getting that most difficult step of installation working. Perhaps you could remove the stick from your butt long enough to reconsider your unfortunate attitude.

    Your PHP installation appears to be missing the MySQL which is required for WordPress.

    This error occurs when your PHP installation does not have the mysql extension installed. Since this extension generally comes with PHP, all you have to do (on Windows) is to edit the PHP.INI file to make it load it. I do not know the specifics of how to make it load that extension on Linux systems, however I suspect it’s similar. Edit the main PHP configuration file, look for “mysql” and there’s probably a line to load the extension that is commented out. Or move the mysql extension file into a different directory or something. I don’t know, refer to your particular PHP documentation.

    Thank you, Otto42. That gives me a direction to pursue.

    FIxed. The solution was to uncomment (enable) the MySQL module in php by removing the semi-colon in: ;extension=mysql.so

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘made MySQL updates but still doesn’t work’ is closed to new replies.
Skip to toolbar