WordPress.org

Forums

made MySQL updates but still doesn't work (7 posts)

  1. glisodin
    Member
    Posted 7 years ago #

    I made the necessary changes to my wp-config.php file:

    DB_NAME
    DB_USER
    DB_PASSWORD

    So I got through step 4 of the Readme (the one that comes in the ZIP file that you download from wordpress.org). But when I try to load /wp-admin/install.php, I get the message:

    "Your PHP installation appears to be missing the MySQL which is required for WordPress."

    What gives?

    Thanks
    PB

  2. cedwin
    Member
    Posted 7 years ago #

    I'm having the same problem. Running PHP v. 4.3.10 (probably no php problem), mysql v. 4.0.27. on FreeBSD 4.7. The mysql resides at usr/local/mysql and has the database I made for WordPress. I have triple-checked everything else in the WordPress installation steps and can find nothing incorrect.

    Yet when I run wp-admin/install.php I get the same message as PB gets:

    "Your PHP installation appears to be missing the MySQL which is required for WordPress."

  3. moshu
    Member
    Posted 7 years ago #

    Having PHP and MySQL installed both - is not the same as having them to "talk" to each other, i.e. to be able to communicate.

    If this happens on your own machine and not in a hosted environment, try to seek help in a specialized forum. We do NOT offer help for server setup.

  4. cedwin
    Member
    Posted 7 years ago #

    Thanks for taking the time to point out the obvious, Moshu, while offering no help. The fact that WordPress requires MySQL tells me that someone should be willing to offer at least a small amount of help in getting that most difficult step of installation working. Perhaps you could remove the stick from your butt long enough to reconsider your unfortunate attitude.

  5. Your PHP installation appears to be missing the MySQL which is required for WordPress.

    This error occurs when your PHP installation does not have the mysql extension installed. Since this extension generally comes with PHP, all you have to do (on Windows) is to edit the PHP.INI file to make it load it. I do not know the specifics of how to make it load that extension on Linux systems, however I suspect it's similar. Edit the main PHP configuration file, look for "mysql" and there's probably a line to load the extension that is commented out. Or move the mysql extension file into a different directory or something. I don't know, refer to your particular PHP documentation.

  6. cedwin
    Member
    Posted 7 years ago #

    Thank you, Otto42. That gives me a direction to pursue.

  7. cedwin
    Member
    Posted 7 years ago #

    FIxed. The solution was to uncomment (enable) the MySQL module in php by removing the semi-colon in: ;extension=mysql.so

Topic Closed

This topic has been closed to new replies.

About this Topic